summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-03-15 11:04:08 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-03-15 11:04:40 +0100
commit12e6e4c886e56942b5417853833ab9f2483cb6f9 (patch)
treeb16633e8215b47bd3afdb7ba38580604e5f3a925 /sys-fs/xfsprogs
parentsys-apps/iproute2: Bump to version 4.5.0 (diff)
downloadgentoo-12e6e4c886e56942b5417853833ab9f2483cb6f9.tar.gz
gentoo-12e6e4c886e56942b5417853833ab9f2483cb6f9.tar.bz2
gentoo-12e6e4c886e56942b5417853833ab9f2483cb6f9.zip
sys-fs/xfsprogs: Bump to version 4.5.0
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/xfsprogs')
-rw-r--r--sys-fs/xfsprogs/Manifest1
-rw-r--r--sys-fs/xfsprogs/xfsprogs-4.5.0.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/sys-fs/xfsprogs/Manifest b/sys-fs/xfsprogs/Manifest
index a60ce64fddab..04a286b6809d 100644
--- a/sys-fs/xfsprogs/Manifest
+++ b/sys-fs/xfsprogs/Manifest
@@ -3,3 +3,4 @@ DIST xfsprogs-3.1.11.tar.gz 1399833 SHA256 adf4980177b5c890c1ca86b9c0e3e4d69a3f9
DIST xfsprogs-3.2.4.tar.gz 1482424 SHA256 dde65ead82d3cbfa9b4ded9796b6d22095d7d759a22d41ae6f1a4ec458bb0465 SHA512 fb1ea5beb933b86970cac198fa4e296457f0f5b30bd72fda54452644730277929dee28f11f35a154910e4a19857455ecffdd21b3df456023e0da95e2fd0aa0eb WHIRLPOOL dec87905b5a5af053e71e88f1670470c00b94a758dbb77773adbc601db61b4efaaba306f344a4334b11680973d5153fcc7f8b5d59c4698f21d654570e8355fe9
DIST xfsprogs-4.2.0.tar.gz 1487831 SHA256 3deab1ad0f4635e54053aa45add27bd48cd87a188c16ac60f4789e01730e5260 SHA512 1bafa9b8eeb834126d02e6e4d582e3ac637ca81c3dc262e3cd742fcc43679ac11a8aa160964264267bc2793822b6af8de87cc7a09c8a9e28826458b17b430620 WHIRLPOOL a608a1b5cad9d22deb26836432730b47ec7a270bbb0e7ff1e41e5a169b5bae5baf143d63129a0ea1936d73a9c479e8787701f9437fdcea2680a41097d64a3437
DIST xfsprogs-4.3.0.tar.gz 1496635 SHA256 3e570ad51153e4be3792f42b2c805ddbd46b55d166eba3102ec87d5006d4cb5c SHA512 c19c07497eb78dd2beb6dc35b8c21abf5fa3ac164eed32f7b95b71d460c8f08bba5550ecc156fafe412bf1b5452e40180e6fcd439d289a660afd594477f209d2 WHIRLPOOL 99661abf6bc31c2ab2e504cdfbcceea2e86b55faed02ec3da0c9d31830b213ae9eb42dc1bcf2612dbbfe2866b538f05f7bb97a60a9ed24a36af0846981825fde
+DIST xfsprogs-4.5.0.tar.gz 1524382 SHA256 e49beb314984efbd0d758abb5c6137db3bb60a88e59e1e94c00defb536cf89f8 SHA512 19c95551dc91ec46916f9a7e3d7976907664d32dd5fdc26af0ca62ca74c4b3c10f9e843aac8214ea9d1c0bf140c9f4e321d059808af01a623abedd5067011314 WHIRLPOOL 54d742635df024a63181da76c3220671610068363af85be2677521f20342595a5cebb2fd169945572351901ee2c9384f79f54a381ab3620dde22d863aa66d469
diff --git a/sys-fs/xfsprogs/xfsprogs-4.5.0.ebuild b/sys-fs/xfsprogs/xfsprogs-4.5.0.ebuild
new file mode 100644
index 000000000000..52c29cc0b385
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-4.5.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libedit nls readline static static-libs"
+REQUIRED_USE="static? ( static-libs )"
+
+LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
+ readline? ( sys-libs/readline:0=[static-libs(+)] )
+ !readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ !<sys-fs/xfsdump-3"
+DEPEND="${RDEPEND}
+ static? (
+ ${LIB_DEPEND}
+ readline? ( sys-libs/ncurses:0=[static-libs] )
+ )
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-sharedlibs.patch
+)
+
+pkg_setup() {
+ if use readline && use libedit ; then
+ ewarn "You have USE='readline libedit' but these are exclusive."
+ ewarn "Defaulting to readline; please disable this USE flag if you want libedit."
+ fi
+}
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+
+ # LLDFLAGS is used for programs, so apply -all-static when USE=static is enabled.
+ # Clear out -static from all flags since we want to link against dynamic xfs libs.
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e "1iLLDFLAGS += $(usex static '-all-static' '')" \
+ include/builddefs.in || die
+ find -name Makefile -exec \
+ sed -i -r -e '/^LLDFLAGS [+]?= -static(-libtool-libs)?$/d' {} +
+
+ # libdisk has broken blkid conditional checking
+ sed -i \
+ -e '/LIB_SUBDIRS/s:libdisk::' \
+ Makefile || die
+
+ # TODO: write a patch for configure.in to use pkg-config for the uuid-part
+ if use static && use readline ; then
+ sed -i \
+ -e 's|-lreadline|\0 -lncurses|' \
+ -e 's|-lblkid|\0 -luuid|' \
+ configure || die
+ fi
+}
+
+src_configure() {
+ export DEBUG=-DNDEBUG
+ export OPTIMIZER=${CFLAGS}
+ unset PLATFORM # if set in user env, this breaks configure
+
+ local myconf
+ if use static || use static-libs ; then
+ myconf+=" --enable-static"
+ else
+ myconf+=" --disable-static"
+ fi
+
+ econf \
+ --bindir=/usr/bin \
+ --libexecdir=/usr/$(get_libdir) \
+ $(use_enable nls gettext) \
+ $(use_enable readline) \
+ $(usex readline --disable-editline $(use_enable libedit editline)) \
+ ${myconf}
+
+ MAKEOPTS+=" V=1"
+}
+
+src_install() {
+ emake DIST_ROOT="${ED}" install
+ # parallel install fails on this target for >=xfsprogs-3.2.0
+ emake -j1 DIST_ROOT="${ED}" install-dev
+
+ # handle is for xfsdump, the rest for xfsprogs
+ gen_usr_ldscript -a xfs xlog
+ # removing unnecessary .la files if not needed
+ use static-libs || find "${ED}" -name '*.la' -delete
+}