summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-09 17:09:54 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-09 17:12:56 -0700
commit5f475748691223f48d0604339a8a1098729104c3 (patch)
treed8410df3ccb4be419034b006124cd762a426f367 /sys-fs
parentsys-fs/zfs-kmod: bump to 0.8.0_rc5, works with linux-5.1 (diff)
downloadgentoo-5f475748691223f48d0604339a8a1098729104c3.tar.gz
gentoo-5f475748691223f48d0604339a8a1098729104c3.tar.bz2
gentoo-5f475748691223f48d0604339a8a1098729104c3.zip
sys-fs/zfs: bump to 0.8.0_rc5
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs/Manifest1
-rw-r--r--sys-fs/zfs/zfs-0.8.0_rc5.ebuild240
2 files changed, 241 insertions, 0 deletions
diff --git a/sys-fs/zfs/Manifest b/sys-fs/zfs/Manifest
index 7d8b4df3603a..d461c803f801 100644
--- a/sys-fs/zfs/Manifest
+++ b/sys-fs/zfs/Manifest
@@ -2,3 +2,4 @@ DIST zfs-0.6.5.11.tar.gz 2521959 BLAKE2B 95b145a26620995343df1a468367b882bc71ab3
DIST zfs-0.7.12.tar.gz 6565017 BLAKE2B 493df30ecce1f169e02d6c8262ba71cc9e7b01d5b17ce188004f522f0c93943b858434067cba8173ccb3e08cde24a1d3e8a3996b2e852f8bc35251f8c4ab3809 SHA512 278e411eac5fb2a91108671b64521c2bd5c08024d5829e1679d8f243dfc3c6317363ed9c79dabfddecf425acb6b3003eeaf4e7d991513cbcae4d2644f5d30bf2
DIST zfs-0.7.13.tar.gz 6614047 BLAKE2B c59c46287715779eb04d69333b0a417fa9865eb0d61c642b043188c4c97d4eed369f76a48327326ed1d4dd608ff95d91d20d26c80ed0b120a8fcd5f83cea638f SHA512 457d8f110b68c9656194cd3738b216d5d807d680e5cfc6ed1f3cf5ebde67860476387c6b862ba3ba7f972d8945075963e6c325543ab84468e3eff5dbce68476e
DIST zfs-0.8.0-rc4.tar.gz 8874029 BLAKE2B 17dd408bfe5133339548c124529b22312c70f527cca9329a7198c415ee2010e03a967d06d6b56ba25c667c8586476daed97c812ffc26331827aac818eda27282 SHA512 0a1137cf5ed2859dd3876867c4f63b74f117847276a3d9de67736a92cbe5a0c9b2e599bb0e84664f5feb89be36188baacdcc2aa233b498fcfeb6fd946c8b73ea
+DIST zfs-0.8.0-rc5.tar.gz 8994022 BLAKE2B f29b9f6d264bbd04553f6855fbdf039808903eb02989e06082d9db8494723e611736db753fa4d27443527fbac189c1ee282ac89fdf799f6182ae428e178d0d10 SHA512 e54a3f9c7947baf619d737a832a545609bc03774a53f9a65147b8c23d9fb5148400a33d99216205a3e45821f8300108882c4eab9995778611775035441428551
diff --git a/sys-fs/zfs/zfs-0.8.0_rc5.ebuild b/sys-fs/zfs/zfs-0.8.0_rc5.ebuild
new file mode 100644
index 000000000000..aae398b670ba
--- /dev/null
+++ b/sys-fs/zfs/zfs-0.8.0_rc5.ebuild
@@ -0,0 +1,240 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit bash-completion-r1 flag-o-matic linux-info linux-mod distutils-r1 systemd toolchain-funcs udev
+
+DESCRIPTION="Userland utilities for ZFS Linux kernel module"
+HOMEPAGE="https://zfsonlinux.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
+else
+ MY_P="${PN}-${PV/_rc/-rc}"
+ SRC_URI="https://github.com/zfsonlinux/${PN}/releases/download/${MY_P}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/zfs-${PV%_rc*}"
+fi
+
+LICENSE="BSD-2 CDDL MIT"
+SLOT="0"
+IUSE="custom-cflags debug kernel-builtin python +rootfs test-suite static-libs"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ net-libs/libtirpc
+ sys-apps/util-linux[static-libs?]
+ sys-libs/zlib[static-libs(+)?]
+ virtual/awk
+ python? (
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ )
+"
+
+BDEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ python? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ !=sys-apps/grep-2.13*
+ !kernel-builtin? ( ~sys-fs/zfs-kmod-${PV} )
+ !sys-fs/zfs-fuse
+ !prefix? ( virtual/udev )
+ sys-fs/udev-init-scripts
+ rootfs? (
+ app-arch/cpio
+ app-misc/pax-utils
+ !<sys-boot/grub-2.00-r2:2
+ !<sys-kernel/genkernel-3.5.1.1
+ !<sys-kernel/genkernel-next-67
+ !<sys-kernel/bliss-initramfs-7.1.0
+ !<sys-kernel/dracut-044-r1
+ )
+ test-suite? (
+ sys-apps/util-linux
+ sys-devel/bc
+ sys-block/parted
+ sys-fs/lsscsi
+ sys-fs/mdadm
+ sys-process/procps
+ virtual/modutils
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/bash-completion-sudo.patch" )
+
+pkg_setup() {
+ if use kernel_linux && use test-suite; then
+ linux-info_pkg_setup
+
+ if ! linux_config_exists; then
+ ewarn "Cannot check the linux kernel configuration."
+ else
+ if use test-suite; then
+ if linux_chkconfig_present BLK_DEV_LOOP; then
+ eerror "The ZFS test suite requires loop device support enabled."
+ eerror "Please enable it:"
+ eerror " CONFIG_BLK_DEV_LOOP=y"
+ eerror "in /usr/src/linux/.config or"
+ eerror " Device Drivers --->"
+ eerror " Block devices --->"
+ eerror " [X] Loopback device support"
+ fi
+ fi
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+
+ [[ ${PV} == "9999" ]] && eautoreconf
+
+ # Update paths
+ sed -e "s|/sbin/lsmod|/bin/lsmod|" \
+ -e "s|/usr/bin/scsi-rescan|/usr/sbin/rescan-scsi-bus|" \
+ -e "s|/sbin/parted|/usr/sbin/parted|" \
+ -i scripts/common.sh.in || die
+
+ if use python; then
+ pushd contrib/pyzfs >/dev/null || die
+ distutils-r1_src_prepare
+ popd >/dev/null || die
+ fi
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+
+ local myconf=(
+ --bindir="${EPREFIX}/bin"
+ --enable-systemd
+ --enable-sysvinit
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=user
+ --with-dracutdir="${EPREFIX}/usr/lib/dracut"
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ --with-udevdir="$(get_udevdir)"
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+ --with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
+ $(use_enable debug)
+ $(use_enable python pyzfs)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ if use python; then
+ pushd contrib/pyzfs >/dev/null || die
+ distutils-r1_src_compile
+ popd >/dev/null || die
+ fi
+}
+
+src_install() {
+ default
+
+ gen_usr_ldscript -a uutil nvpair zpool zfs zfs_core
+
+ use test-suite || rm -rf "${ED}/usr/share/zfs"
+
+ dobashcomp contrib/bash_completion.d/zfs
+ bashcomp_alias zfs zpool
+
+ # strip executable bit from conf.d file
+ fperms 0644 /etc/conf.d/zfs
+
+ if use python; then
+ pushd contrib/pyzfs >/dev/null || die
+ distutils-r1_src_install
+ popd >/dev/null || die
+ fi
+
+ # enforce best available python implementation
+ python_setup
+ python_fix_shebang "${ED}/bin"
+}
+
+pkg_postinst() {
+ if ! use kernel-builtin && [[ ${PV} = "9999" ]]; then
+ einfo "Adding ${P} to the module database to ensure that the"
+ einfo "kernel modules and userland utilities stay in sync."
+ update_moduledb
+ fi
+
+ if [[ -e "${EROOT}/etc/runlevels/boot/zfs" ]]; then
+ einfo 'The zfs boot script has been split into the zfs-import,'
+ einfo 'zfs-mount and zfs-share scripts.'
+ einfo
+ einfo 'You had the zfs script in your boot runlevel. For your'
+ einfo 'convenience, it has been automatically removed and the three'
+ einfo 'scripts that replace it have been configured to start.'
+ einfo 'The zfs-import and zfs-mount scripts have been added to the boot'
+ einfo 'runlevel while the zfs-share script is in the default runlevel.'
+
+ rm "${EROOT}/etc/runlevels/boot/zfs"
+ ln -snf "${EROOT}/etc/init.d/zfs-import" \
+ "${EROOT}/etc/runlevels/boot/zfs-import"
+ ln -snf "${EROOT}/etc/init.d/zfs-mount" \
+ "${EROOT}/etc/runlevels/boot/zfs-mount"
+ ln -snf "${EROOT}/etc/init.d/zfs-share" \
+ "${EROOT}/etc/runlevels/default/zfs-share"
+ else
+ [[ -e "${EROOT}/etc/runlevels/boot/zfs-import" ]] || \
+ einfo "You should add zfs-import to the boot runlevel."
+ [[ -e "${EROOT}/etc/runlevels/boot/zfs-mount" ]]|| \
+ einfo "You should add zfs-mount to the boot runlevel."
+ [[ -e "${EROOT}/etc/runlevels/default/zfs-share" ]] || \
+ einfo "You should add zfs-share to the default runlevel."
+ fi
+
+ if [[ -e "${EROOT}/etc/runlevels/default/zed" ]]; then
+ einfo 'The downstream OpenRC zed script has replaced by the upstream'
+ einfo 'OpenRC zfs-zed script.'
+ einfo
+ einfo 'You had the zed script in your default runlevel. For your'
+ einfo 'convenience, it has been automatically removed and the zfs-zed'
+ einfo 'script that replaced it has been configured to start.'
+
+ rm "${EROOT}/etc/runlevels/boot/zed"
+ ln -snf "${EROOT}/etc/init.d/zfs-zed" \
+ "${EROOT}/etc/runlevels/default/zfs-zed"
+ else
+ [[ -e "${EROOT}/etc/runlevels/default/zfs-zed" ]] || \
+ einfo "You should add zfs-zed to the default runlevel."
+ fi
+
+ if [[ -e "${EROOT}/etc/runlevels/shutdown/zfs-shutdown" ]]; then
+ einfo "The zfs-shutdown script is obsolete. Removing it from runlevel."
+ rm "${EROOT}/etc/runlevels/shutdown/zfs-shutdown"
+ fi
+
+ systemd_reenable zfs-zed.service
+ systemd_reenable zfs-import-cache.service
+ systemd_reenable zfs-import-scan.service
+ systemd_reenable zfs-mount.service
+ systemd_reenable zfs-share.service
+ systemd_reenable zfs-import.target
+ systemd_reenable zfs.target
+}
+
+pkg_postrm() {
+ if ! use kernel-builtin && [[ ${PV} == "9999" ]]; then
+ remove_moduledb
+ fi
+}