summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-17 01:57:54 +0000
committerSam James <sam@gentoo.org>2020-08-17 01:58:01 +0000
commit80134effaa1cfff7c9dc6d9b72d356f5425f01d3 (patch)
tree39094632ea841abbecdaca0d8074794295f90e1d /sys-fs
parentsys-devel/gnuconfig: mark ALLARCHES (diff)
downloadgentoo-80134effaa1cfff7c9dc6d9b72d356f5425f01d3.tar.gz
gentoo-80134effaa1cfff7c9dc6d9b72d356f5425f01d3.tar.bz2
gentoo-80134effaa1cfff7c9dc6d9b72d356f5425f01d3.zip
sys-fs/ecryptfs-utils: fix musl build
Include a simple patch from Alpine Linux to fix the build on musl. Closes: https://bugs.gentoo.org/715508 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-111_p20170609-r1.ebuild4
-rw-r--r--sys-fs/ecryptfs-utils/files/ecryptfs-utils-111-musl-fix.patch13
2 files changed, 17 insertions, 0 deletions
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-111_p20170609-r1.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-111_p20170609-r1.ebuild
index 855dfb66132b..d11d30dd0ffc 100644
--- a/sys-fs/ecryptfs-utils/ecryptfs-utils-111_p20170609-r1.ebuild
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-111_p20170609-r1.ebuild
@@ -39,6 +39,10 @@ DEPEND="
dev-libs/glib:2
"
+PATCHES=(
+ "${FILESDIR}/${PN}-111-musl-fix.patch"
+)
+
pkg_setup() {
CONFIG_CHECK="~ECRYPT_FS"
linux-info_pkg_setup
diff --git a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-111-musl-fix.patch b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-111-musl-fix.patch
new file mode 100644
index 000000000000..1d6de38e8cb3
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-111-musl-fix.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/715508
+https://git.alpinelinux.org/aports/tree/community/ecryptfs-utils/fix-build.patch?id=9e57b1f1197ee99b9f998472371042c42bffdc49
+--- a/src/utils/mount.ecryptfs_private.c 2016-01-22 18:04:52.000000000 +0200
++++ b/src/utils/mount.ecryptfs_private.c 2017-01-20 08:39:31.877975729 +0200
+@@ -235,7 +235,7 @@
+ * deceive other programs with a crafted /proc/self/*. See
+ * https://launchpad.net/bugs/1530566 for more details.
+ */
+- __SWORD_TYPE f_type_whitelist[] = {
++ static const uint32_t f_type_whitelist[] = {
+ 0x61756673 /* AUFS_SUPER_MAGIC */,
+ 0x9123683E /* BTRFS_SUPER_MAGIC */,
+ 0x00C36400 /* CEPH_SUPER_MAGIC */,