summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-07-02 17:27:34 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-07-02 17:30:21 -0400
commitaefa81287461cd42531728e7c344df35d875aae4 (patch)
treebe59fc7e9fc155a1b1bbd98aab4970aecc52879c /sys-fs
parentdev-lisp/cl-unicode: Fixes metadata formatting (diff)
downloadgentoo-aefa81287461cd42531728e7c344df35d875aae4.tar.gz
gentoo-aefa81287461cd42531728e7c344df35d875aae4.tar.bz2
gentoo-aefa81287461cd42531728e7c344df35d875aae4.zip
sys-fs/f2fs-tools: version bump to 1.8.0
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/f2fs-tools/Manifest1
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.8.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/Manifest b/sys-fs/f2fs-tools/Manifest
index 211436586cf4..0ba6fe67491e 100644
--- a/sys-fs/f2fs-tools/Manifest
+++ b/sys-fs/f2fs-tools/Manifest
@@ -1,3 +1,4 @@
DIST f2fs-tools-1.6.0.tar.xz 278644 SHA256 90459d4252958911a722a223e825f4d02e4539492e6a59ff8cdbf155c8ca1899 SHA512 043d4aa25798fa39e637def4e03b4a5e89c9ae4880832abf09805dfc851111045c3c779d36c1a91cb4ee74857b483f0ef2f8d9a541e3a695a8c5bc9bcfa46a8f WHIRLPOOL c8d3889d83f479f643a229f90c0151428a5a6c516820e579a8562bc701b7747385205732c1163dd6f1cfc2c47d5111133357af9a94f1c8d6f0218a70751a78a0
DIST f2fs-tools-1.6.1.tar.xz 282152 SHA256 1c2f9ab663d26c939924ad6bbcfbacf676bec1f6dbae8f9ef5362ade4b03d885 SHA512 108327042079d9e864899a20f2dd94019be1b957fd7ffa295af097c5b93a5065ea9c36de9bae83f84a6412ac496340849fc44de041e24461a2919073eed15cf2 WHIRLPOOL b5659154da6e48138b4f49481a68b25c95ba2461971609b4cb0399d173a7c0e5b0203baccd8da2adc7a8c2d7b078620649aea9ee57739498452a8b946fb43836
DIST f2fs-tools-1.7.0.tar.xz 301320 SHA256 d2f9138694b5ca12f54a4f897516b4db746a8009f4ba10feb3eb9a34435ed6aa SHA512 3751820e6fda719f906c388c74ce018ac2aea874701c4579e5d02a3c71a8413efd4d35f6c4c6e88cb2abf030d6616d045eb9a81572b9654e068d968c17269959 WHIRLPOOL c0152a6715b318a8aab808a282d9baf085b108e6ab7d390083d12d8437b4ea32c0339846ecf0f72a0b0407f6d7556232c65cc75628830527eea6f8ec3a225a19
+DIST f2fs-tools-1.8.0.tar.xz 301108 SHA256 0d9b00d9e873da4508bb297c7a5ef46050af350deb21b32898c16ed5164bb6a4 SHA512 aff27e1113cc3034194e496883570143bd6a3cc7cc077e868255052298a401cc36c423579b4e695fe3e480d770ae05f9d14d9bb4bbc0311bdd5e23e37950a27f WHIRLPOOL 4a7ae8533e4a02bd9d1ee09461c7bd30e8ef8d47bcc4e7adfe631eb14c2231fb0db9a253eeca7d0437296ad65abd446ab2249bc48ccc07b89f923d078d17e4dc
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.8.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.8.0.ebuild
new file mode 100644
index 000000000000..55be42c32413
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE="selinux"
+
+RDEPEND="
+ sys-apps/util-linux
+ selinux? ( sys-libs/libselinux )"
+DEPEND="$RDEPEND"
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}