summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-08-01 14:44:00 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-08-01 14:46:44 +0900
commitc42c9b0ad61f53caa4f13789fde90f3b7ee2bef2 (patch)
treeba87305e59423c4f899b3253c42c011a3255a6a1 /sys-fs
parentdev-ruby/sqlite3: uncomment rdoc code, bug 589934 (diff)
downloadgentoo-c42c9b0ad61f53caa4f13789fde90f3b7ee2bef2.tar.gz
gentoo-c42c9b0ad61f53caa4f13789fde90f3b7ee2bef2.tar.bz2
gentoo-c42c9b0ad61f53caa4f13789fde90f3b7ee2bef2.zip
sys-fs/eudev: Prefix support.
Bug: 589796
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/eudev/eudev-3.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-fs/eudev/eudev-3.2.ebuild b/sys-fs/eudev/eudev-3.2.ebuild
index e70d95411c64..7e2730d6c9c6 100644
--- a/sys-fs/eudev/eudev-3.2.ebuild
+++ b/sys-fs/eudev/eudev-3.2.ebuild
@@ -108,19 +108,19 @@ multilib_src_configure() {
DBUS_LIBS=' '
--with-rootprefix=
--with-rootrundir=/run
- --libdir=/usr/$(get_libdir)
- --with-rootlibexecdir=/lib/udev
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --with-rootlibexecdir="${EPREFIX}"/lib/udev
--enable-split-usr
--enable-manpages
--disable-hwdb
- --exec-prefix=/
+ --exec-prefix="${EPREFIX}"
)
# Only build libudev for non-native_abi, and only install it to libdir,
# that means all options only apply to native_abi
if multilib_is_native_abi; then
econf_args+=(
- --with-rootlibdir=/$(get_libdir)
+ --with-rootlibdir="${EPREFIX}"/$(get_libdir)
$(use_enable introspection)
$(use_enable kmod)
$(use_enable static-libs static)