summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-01-31 04:10:22 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-01-31 16:15:26 +0100
commitc592c8103eb30fbe6905a369410e99e82f413a97 (patch)
tree6881373177b51ff4a347d20ea34f9300bcc50990 /sys-fs
parentsys-auth/AusweisApp2: add 1.26.2 (diff)
downloadgentoo-c592c8103eb30fbe6905a369410e99e82f413a97.tar.gz
gentoo-c592c8103eb30fbe6905a369410e99e82f413a97.tar.bz2
gentoo-c592c8103eb30fbe6905a369410e99e82f413a97.zip
sys-fs/cryptmount: add 6.2.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptmount/Manifest1
-rw-r--r--sys-fs/cryptmount/cryptmount-6.2.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sys-fs/cryptmount/Manifest b/sys-fs/cryptmount/Manifest
index 591f67c91aba..899267c28d38 100644
--- a/sys-fs/cryptmount/Manifest
+++ b/sys-fs/cryptmount/Manifest
@@ -1 +1,2 @@
DIST cryptmount-6.1.0.tar.gz 548225 BLAKE2B 71039c7e2d3fb82fdd4797ce829ce7731c3b6b61c30730b1c5da449d2a559ed6cf8026527f6ed2f6d0b134327e0b3ca54f626cc42e528317f00d29001ead01b5 SHA512 a8f43dc9d4cbc87be4fde96a5b79d44bb154ef5b79f353daee1128728c537c8a10a5324a4c4a39d7926fd393bf944da5aaf4e279ff325f7fe47a01559ae5b1d5
+DIST cryptmount-6.2.0.tar.gz 548497 BLAKE2B 45602d86624464c8c1c2ad9cf3ffc4bf311d60ae16c2294111b1fc98bb0e02952c69c767a1c583428c3d8eb0ade2caddb17d3187f4dd34d780772b299ea1a6c0 SHA512 005d9333792a567515ce6d487d2dfa18f19cb077a64d9c356562acefc1947581d2d0f584ad623e0aab8aed1b34f1614af3a42f0c582d31e0831cdb8eb22bb7ce
diff --git a/sys-fs/cryptmount/cryptmount-6.2.0.ebuild b/sys-fs/cryptmount/cryptmount-6.2.0.ebuild
new file mode 100644
index 000000000000..c46c12cd6220
--- /dev/null
+++ b/sys-fs/cryptmount/cryptmount-6.2.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
+HOMEPAGE="http://cryptmount.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="argv0switch cswap fsck +gcrypt +largefile mount +nls +luks +openssl selinux systemd udev"
+REQUIRED_USE="
+ luks? ( gcrypt )
+ openssl? ( gcrypt )
+"
+
+RDEPEND="
+ sys-fs/lvm2
+ virtual/libiconv
+ virtual/libintl
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ luks? ( sys-fs/cryptsetup )
+ openssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd )
+ udev? ( virtual/udev )
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+"
+
+BDEPEND="nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="BLK_DEV_DM"
+ERROR_BLK_DEV_DM="
+ Please enable Device Mapper support in your kernel config
+ -> Device Drivers
+ -> Multiple devices driver support (RAID and LVM)
+ -> Multiple devices driver support (RAID and LVM)
+ <*>/<M> Device mapper support
+"
+
+src_prepare() {
+ default
+
+ # Since SELinux is hardcoded, remove it on disabled SELinux profile
+ if ! use selinux; then
+ sed -e '/selinux/d' -i dmutils.c || die
+ fi
+}
+
+src_configure() {
+ local myeconf=(
+ --disable-rpath
+ $(use_enable argv0switch)
+ $(use_enable cswap)
+ $(use_enable fsck)
+ $(use_with gcrypt libgcrypt)
+ $(use_enable largefile)
+ $(use_enable mount delegation)
+ $(use_enable nls)
+ $(use_enable luks)
+ $(use_enable openssl openssl-compat)
+ $(use_with systemd)
+ $(use_enable udev libudev)
+
+ )
+
+ econf "${myeconf[@]}"
+}