summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-07 10:57:00 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-07 11:20:33 +0100
commitf7686259aad01f4d04e112df4175632fa0cfbab0 (patch)
treeebb6fa6ed40afe3a7a168f9b583a7b81c5f07b39 /sys-fs
parentsys-libs/e2fsprogs-libs: Bump to version 1.45.0 (diff)
downloadgentoo-f7686259aad01f4d04e112df4175632fa0cfbab0.tar.gz
gentoo-f7686259aad01f4d04e112df4175632fa0cfbab0.tar.bz2
gentoo-f7686259aad01f4d04e112df4175632fa0cfbab0.zip
sys-fs/e2fsprogs: Bump to version 1.45.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/Manifest1
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.45.0.ebuild138
2 files changed, 139 insertions, 0 deletions
diff --git a/sys-fs/e2fsprogs/Manifest b/sys-fs/e2fsprogs/Manifest
index c7ea7502daad..cb6b15aa7c8f 100644
--- a/sys-fs/e2fsprogs/Manifest
+++ b/sys-fs/e2fsprogs/Manifest
@@ -2,3 +2,4 @@ DIST e2fsprogs-1.42.9-mint-r1.patch.xz 9012 BLAKE2B ae6421587c3cca2f9b26805c5f8d
DIST e2fsprogs-1.43.9.tar.gz 7470878 BLAKE2B dcc1a6fda87884a0b3b1d49f4116be060bf39c4820246ba6aa7ce61c6735415542f852b36d3c809b2b52782de2ca9ea9a87086a0d4ff71ee217845939aae00f1 SHA512 7bdc5da165b14e6779aedd9243175018ca8cb2bb0f5aad9c3d04f7e0619da2107f37929e6d8027b682145801106f97d1376345c4c30ce64f2b02b716b0c4ba3b
DIST e2fsprogs-1.44.5.tar.xz 5375996 BLAKE2B a6069e7c4889cdd3a30d94994d179c024edf098205012446677c76ed206f18e71a0f241527ac33ee35eebdfa8fe87a81dde5228694186fc4e1e55e5b7bc87862 SHA512 c0faec90b2be81460d374c150be917cd6beb1d10dc7cd0c6c4747de19de9af1763e90d48aec5b3c0fbff1b59bf79a35f93536cd52e68d1e45d4db610e158bb2e
DIST e2fsprogs-1.44.6.tar.xz 5378560 BLAKE2B 1430e87fbfc81cf299c3b577c46309e2ca2ff5a8de7121a9aab7a8ea49693fd1053f3f034c4f9105b2cc0c3395b7887d3284493c9105287c4f03deebc237ace5 SHA512 725ff908148b55d9417aa9e01f514feb434c43441f7104c61d200fcdf6b30b528f62475bdffc9e1c49d3d44e1e3f2cc1e9df60025c8e3d113d6edabfccf356bf
+DIST e2fsprogs-1.45.0.tar.xz 5520532 BLAKE2B de7c27b90e68e822a8157e99d103933d98afe094765016a58dbdce4d5bebda86493c94dbf3bd009aa25063edf34a0c8229cbc1045f1041a357448619aee55de8 SHA512 208f0508dd355f29f9428758123e84d7f73d1a0bba4fcdc5abb561dc492ed1ab7e36ce369acde5c26e9efff0b980d75047d2d5910d3e49614cc68ec770dc9014
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.45.0.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.45.0.ebuild
new file mode 100644
index 000000000000..8dc1b6efbfd7
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.45.0.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.xz
+ mirror://kernel/linux/kernel/people/tytso/e2fsprogs/v${PV}/${P}.tar.xz
+ elibc_mintlib? ( mirror://gentoo/${PN}-1.42.9-mint-r1.patch.xz )"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint"
+IUSE="fuse nls static-libs elibc_FreeBSD"
+
+RDEPEND="~sys-libs/${PN}-libs-${PV}
+ >=sys-apps/util-linux-2.16
+ fuse? ( sys-fs/fuse:0 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ sys-apps/texinfo"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.44.6-parallel_install.patch
+ "${FILESDIR}"/${PN}-1.40-fbsd.patch
+ "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
+
+ # Upstream patches (can usually removed with next version bump)
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-mint* ]] ; then
+ PATCHES+=( "${WORKDIR}"/${PN}-1.42.9-mint-r1.patch )
+ fi
+
+ default
+
+ cp doc/RelNotes/v${PV}.txt ChangeLog || die "Failed to copy Release Notes"
+
+ # Get rid of doc -- we don't use them. This also prevents a sandbox
+ # violation due to mktexfmt invocation
+ rm -r doc || die "Failed to remove doc dir"
+
+ # blargh ... trick e2fsprogs into using e2fsprogs-libs
+ sed -i -r \
+ -e 's:@LIBINTL@:@LTLIBINTL@:' \
+ -e '/^(STATIC_)?LIB(COM_ERR|SS)/s:[$][(]LIB[)]/lib([^@]*)@(STATIC_)?LIB_EXT@:-l\1:' \
+ -e '/^DEP(STATIC_)?LIB(COM_ERR|SS)/s:=.*:=:' \
+ MCONFIG.in || die "muck libs" #122368
+ sed -i -r \
+ -e '/^LIB_SUBDIRS/s:lib/(et|ss)::g' \
+ Makefile.in || die "remove subdirs"
+ ln -s $(which mk_cmds) lib/ss/ || die
+
+ # Avoid rebuild
+ echo '#include_next <ss/ss_err.h>' > lib/ss/ss_err.h
+}
+
+src_configure() {
+ # Keep the package from doing silly things #261411
+ export VARTEXFONTS="${T}/fonts"
+
+ # needs open64() prototypes and friends
+ append-cppflags -D_GNU_SOURCE
+
+ local myeconfargs=(
+ --with-root-prefix="${EPREFIX%/}/"
+ --enable-symlink-install
+ --enable-elf-shlibs
+ $(tc-has-tls || echo --disable-tls)
+ --without-included-gettext
+ $(use_enable fuse fuse2fs)
+ $(use_enable nls)
+ --disable-libblkid
+ --disable-libuuid
+ --disable-fsck
+ --disable-uuidd
+ )
+ ac_cv_path_LDCONFIG=: econf "${myeconfargs[@]}"
+
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to https://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+}
+
+src_compile() {
+ emake V=1 COMPILE_ET=compile_et MK_CMDS=mk_cmds
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c .
+ emake V=1 fsck_ext2fs
+ fi
+}
+
+src_install() {
+ # need to set root_libdir= manually as any --libdir options in the
+ # econf above (i.e. multilib) will screw up the default #276465
+ emake \
+ STRIP=: \
+ root_libdir="${EPREFIX%/}/usr/$(get_libdir)" \
+ DESTDIR="${D%/}" \
+ install install-libs
+
+ einstalldocs
+
+ insinto /etc
+ doins "${FILESDIR}"/e2fsck.conf
+
+ # Move shared libraries to /lib/, install static libraries to
+ # /usr/lib/, and install linker scripts to /usr/lib/.
+ gen_usr_ldscript -a e2p ext2fs
+
+ # configure doesn't have an option to disable static libs :/
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs
+ doman "${FILESDIR}"/fsck_ext2fs.8
+
+ # filefrag is linux only
+ rm \
+ "${ED%/}"/usr/sbin/filefrag \
+ "${ED%/}"/usr/share/man/man8/filefrag.8 || die
+ fi
+}