summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-18 18:44:54 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-18 18:44:54 -0400
commitf7fb67a36e6da64632bcf5b12dc2cf95f4a0fd9d (patch)
tree47e57fa3cac55eb97481eef2481c8a0d9376d37d /sys-fs
parentsys-apps/sg3_utils: fix build w/newer glibc #580236 (diff)
downloadgentoo-f7fb67a36e6da64632bcf5b12dc2cf95f4a0fd9d.tar.gz
gentoo-f7fb67a36e6da64632bcf5b12dc2cf95f4a0fd9d.tar.bz2
gentoo-f7fb67a36e6da64632bcf5b12dc2cf95f4a0fd9d.zip
sys-fs/cramfs: convert to EAPI=5
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cramfs/cramfs-1.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-fs/cramfs/cramfs-1.1.ebuild b/sys-fs/cramfs/cramfs-1.1.ebuild
index 557bcb1f2149..42a69d6f1254 100644
--- a/sys-fs/cramfs/cramfs-1.1.ebuild
+++ b/sys-fs/cramfs/cramfs-1.1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
+
+EAPI="5"
inherit toolchain-funcs
DESCRIPTION="Linux filesystem designed to be simple, small, and to compress things well"
-HOMEPAGE="http://sourceforge.net/projects/cramfs/"
+HOMEPAGE="https://sourceforge.net/projects/cramfs/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
@@ -14,13 +15,14 @@ KEYWORDS="alpha amd64 ppc ~sparc x86"
IUSE=""
DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
src_compile() {
- emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
}
src_install() {
into /
- dosbin mkcramfs cramfsck || die
+ dosbin mkcramfs cramfsck
dodoc README NOTES
}