summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Vasquez <fearedbliss@gentoo.org>2017-07-01 12:38:14 -0400
committerJonathan Vasquez <fearedbliss@gentoo.org>2017-07-01 12:38:33 -0400
commita78acf49790709cff0eb33b925cb94d658445a9e (patch)
tree8935d17f112acbfa79eda0248b372eb567ba6e85 /sys-kernel/bliss-initramfs/bliss-initramfs-7.1.0.ebuild
parentdev-ada/xmlada: rm 9999 version (diff)
downloadgentoo-a78acf49790709cff0eb33b925cb94d658445a9e.tar.gz
gentoo-a78acf49790709cff0eb33b925cb94d658445a9e.tar.bz2
gentoo-a78acf49790709cff0eb33b925cb94d658445a9e.zip
sys-kernel/bliss-initramfs: version bump to 7.1.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-kernel/bliss-initramfs/bliss-initramfs-7.1.0.ebuild')
-rw-r--r--sys-kernel/bliss-initramfs/bliss-initramfs-7.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/bliss-initramfs/bliss-initramfs-7.1.0.ebuild b/sys-kernel/bliss-initramfs/bliss-initramfs-7.1.0.ebuild
new file mode 100644
index 000000000000..c772363314bc
--- /dev/null
+++ b/sys-kernel/bliss-initramfs/bliss-initramfs-7.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+inherit python-single-r1
+
+GITHUB_USER="fearedbliss"
+GITHUB_REPO="bliss-initramfs"
+GITHUB_TAG="${PV}"
+
+DESCRIPTION="Boot your system's rootfs from ZFS, LVM, RAID, or a variety of other configs."
+HOMEPAGE="https://github.com/${GITHUB_USER}/${GITHUB_REPO}"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_REPO}/archive/${GITHUB_TAG}.tar.gz -> ${P}.tar.gz"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="strip"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-arch/cpio
+ virtual/udev"
+
+S="${WORKDIR}/${GITHUB_REPO}-${GITHUB_TAG}"
+
+src_install() {
+ # Copy the main executable
+ local executable="mkinitrd.py"
+ exeinto "/opt/${PN}"
+ doexe "${executable}"
+
+ # Copy the libraries required by this executable
+ cp -r "${S}/files" "${D}/opt/${PN}" || die
+ cp -r "${S}/pkg" "${D}/opt/${PN}" || die
+
+ # Copy documentation files
+ dodoc README USAGE
+
+ # Make a symbolic link: /sbin/bliss-initramfs
+ dosym "/opt/${PN}/${executable}" "/sbin/${PN}"
+}