summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSarah White <kuzetsa@poindexter.ovh>2018-10-11 05:55:51 -0400
committerThomas Deutschmann <whissi@gentoo.org>2018-10-12 02:56:40 +0200
commita660268309e4254ba63e659367ab2c5257e10615 (patch)
tree25a4b3d62c8493eb04f16d1bd6f5bd4e3877b7f6 /sys-kernel/ck-sources/ck-sources-4.18.13.ebuild
parentsys-kernel/ck-sources: version 4.14.75 (diff)
downloadgentoo-a660268309e4254ba63e659367ab2c5257e10615.tar.gz
gentoo-a660268309e4254ba63e659367ab2c5257e10615.tar.bz2
gentoo-a660268309e4254ba63e659367ab2c5257e10615.zip
sys-kernel/ck-sources: version 4.18.13
updated to genpatches-4.18-16 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Sarah White <kuzetsa@poindexter.ovh> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-4.18.13.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.18.13.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-4.18.13.ebuild b/sys-kernel/ck-sources/ck-sources-4.18.13.ebuild
new file mode 100644
index 000000000000..1c6f9715c18a
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-4.18.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2018 kuzetsa℠ and others
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/
+ http://kernel.kolivas.org/"
+
+IUSE="experimental"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="16"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 kernel-2
+detect_version
+detect_arch
+
+DEPEND="deblob? ( ${PYTHON_DEPS} )"
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Gentoo's genpatches for Linux ${K_BRANCH_ID}, with Con Kolivas' MuQSS process scheduler."
+
+MUQSS_VERSION="173"
+MUQSS_FILE="0001-MultiQueue-Skiplist-Scheduler-version-v0.${MUQSS_VERSION}.patch"
+MUQSS_BASE_URL="http://ck.kolivas.org/patches/muqss/4.0"
+
+# clearly identify package name in distrdir
+MUQSS_DISTNAME="${PN}-${K_BRANCH_ID}-muqss.patch"
+
+CK_LVER_URL="${MUQSS_BASE_URL}/${K_BRANCH_ID}"
+CK_URI="${CK_LVER_URL}/${MUQSS_FILE} -> ${MUQSS_DISTNAME}"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${MUQSS_DISTNAME}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_setup() {
+ use deblob && python-any-r1_pkg_setup
+ kernel-2_pkg_setup
+}