summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2017-03-22 10:38:26 +0100
committerMarek Szuba <marecki@gentoo.org>2017-03-22 10:38:26 +0100
commit2d3c92e5d6daa6b96321c3392abc319cc8bb8098 (patch)
tree27d0b1a87ef7104c164f97e1d7cd4ad679410da2 /sys-kernel/cryptodev
parentapp-forensics/yasat: bump to 848 (diff)
downloadgentoo-2d3c92e5d6daa6b96321c3392abc319cc8bb8098.tar.gz
gentoo-2d3c92e5d6daa6b96321c3392abc319cc8bb8098.tar.bz2
gentoo-2d3c92e5d6daa6b96321c3392abc319cc8bb8098.zip
sys-kernel/cryptodev: add live ebuild
Requested-By: Corentin Labbe <clabbe.montjoie@gmail.com> Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-kernel/cryptodev')
-rw-r--r--sys-kernel/cryptodev/cryptodev-9999.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-kernel/cryptodev/cryptodev-9999.ebuild b/sys-kernel/cryptodev/cryptodev-9999.ebuild
new file mode 100644
index 000000000000..1576432f2360
--- /dev/null
+++ b/sys-kernel/cryptodev/cryptodev-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info linux-mod
+
+DESCRIPTION="device that allows access to Linux kernel cryptographic drivers"
+HOMEPAGE="http://cryptodev-linux.org/index.html"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/cryptodev-linux/cryptodev-linux.git"
+ S="${WORKDIR}/${PN}-${PV}"
+else
+ SRC_URI="http://download.gna.org/cryptodev-linux/${PN}-linux-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}/${PN}-linux-${PV}
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+#test now compile, but need the module to run
+RESTRICT="test"
+
+MODULE_NAMES="cryptodev(extra:${S})"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ CONFIG_CHECK="~CRYPTO ~CRYPTO_BLKCIPHER ~CRYPTO_AEAD"
+ check_extra_config
+ fi
+}
+
+pkg_setup() {
+ if use kernel_linux ; then
+ linux-mod_pkg_setup
+ else
+ die "cryptodev ebuild only support linux"
+ fi
+ BUILD_TARGETS="build"
+ export KERNEL_DIR
+}
+
+src_install() {
+ linux-mod_src_install
+ if use examples ; then
+ docinto examples
+ dodoc example/*
+ fi
+ insinto /usr/include/crypto
+ doins crypto/cryptodev.h
+}