summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2017-01-23 20:18:45 +0100
committerAgostino Sarubbo <ago@gentoo.org>2017-01-23 20:18:45 +0100
commit0013fdbe2b7fcce01c11cdcd80e0c538f100076c (patch)
treeed66275c7c4ee49bd7f0ef0ade0d9cfedf10d590 /sys-kernel/git-sources/git-sources-4.10_rc5.ebuild
parentnet-wireless/gnuradio: bug #593052, unported changes on last bump (diff)
downloadgentoo-0013fdbe2b7fcce01c11cdcd80e0c538f100076c.tar.gz
gentoo-0013fdbe2b7fcce01c11cdcd80e0c538f100076c.tar.bz2
gentoo-0013fdbe2b7fcce01c11cdcd80e0c538f100076c.zip
sys-kernel/git-sources: Automated version bump to 4.10_rc5.
Package-Manager: portage-2.3.0 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources/git-sources-4.10_rc5.ebuild')
-rw-r--r--sys-kernel/git-sources/git-sources-4.10_rc5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/git-sources-4.10_rc5.ebuild b/sys-kernel/git-sources/git-sources-4.10_rc5.ebuild
new file mode 100644
index 000000000000..05f9017871b5
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.10_rc5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.9"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}