summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-03-24 18:13:09 -0400
committerMike Pagano <mpagano@gentoo.org>2024-03-24 18:13:09 -0400
commit1bfde962e898d00ac95966b9d47b3903bc8ff364 (patch)
tree9456c5e4f375bb723816f99536c1606b52d0c623 /sys-kernel/git-sources
parentsci-libs/gmsh: drop 4.9.5-r3, 4.10.3-r1 (diff)
downloadgentoo-1bfde962e898d00ac95966b9d47b3903bc8ff364.tar.gz
gentoo-1bfde962e898d00ac95966b9d47b3903bc8ff364.tar.bz2
gentoo-1bfde962e898d00ac95966b9d47b3903bc8ff364.zip
sys-kernel/git-sources: add 6.9_rc1
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.9_rc1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index c9fe0164b5f3..68e4afa3d3ea 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -6,3 +6,4 @@ DIST patch-6.8-rc4.patch 44748761 BLAKE2B da6da63a288680039ea72412fad9c51cd0dcab
DIST patch-6.8-rc5.patch 45206799 BLAKE2B 629c0a1abd3e41b0f9e8b8c0ddcad75526948872b29371dba16f94e00a846c1c4b811c41446a7d686a533b858d20d66138d26d444a4021976bbcc0108cc17a66 SHA512 e693b249300093cb300445e102747e97fa84a2ffe989b0684aed83573357e805640b0442272be5e064899ce91b82b8917cfe5f1350cac6d2c3287959276b7c8a
DIST patch-6.8-rc6.patch 45546090 BLAKE2B a9775d50d71233a6f2c24236e12a6cfcf8b1439f5fed8fbaa89bb45150a7b08cea8e6a37e6eb9a72e1321239d5d3277388f876256fcbc6df4b4b32f057125762 SHA512 a5434e310131c5db6c8a40e4fae665f000db68073a05f63e66afd9abbbaf5c3fefc72574dc71e6b60e2641b149ef68337fcb882e898d5aff047b1f631052b094
DIST patch-6.8-rc7.patch 45742179 BLAKE2B 3f38c49eef506cc809894f42ec3bf2170451d2f41d4201de52c75e5bea77972f546c0d9b7669d700c988a70abdbc2a75b6abd3e104e95ab7eac8b64b96bec51d SHA512 97ea715c61f33fa1abbe4abd81eaf776ea285955355c30f1148e35262c53db815462b5169f935424e6afedb560213aef62d64cdfac0bd74496470763ec0e5694
+DIST patch-6.9-rc1.patch 96098154 BLAKE2B c7ab938924bf2b159da4ef02730ce3e51beab9a9267419e195861a5de4962facca4937ce1f8d9451d99723e8af30b2cd6c20f01868cf9a9e935d225cad462ff1 SHA512 2f094d30277ae51bc9451565ba3e0e03cb12f331239f974bf7713fbd17b4aac73722e46b425aaedd22d42b73767b234f26f8e9e24cac8ad5d5a7e0e5aeb94638
diff --git a/sys-kernel/git-sources/git-sources-6.9_rc1.ebuild b/sys-kernel/git-sources/git-sources-6.9_rc1.ebuild
new file mode 100644
index 000000000000..ca760a458b08
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.9_rc1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.7"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}