summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-02-25 20:45:58 -0500
committerMike Pagano <mpagano@gentoo.org>2024-02-25 20:45:58 -0500
commit67b6b51bd8dc2fd18da0f7b816bccadaeaa6f838 (patch)
tree8544415dd0b2c57fca2160560835a17ec1eed58c /sys-kernel/git-sources
parentsys-apps/tuned: drop 2.21.0 (diff)
downloadgentoo-67b6b51bd8dc2fd18da0f7b816bccadaeaa6f838.tar.gz
gentoo-67b6b51bd8dc2fd18da0f7b816bccadaeaa6f838.tar.bz2
gentoo-67b6b51bd8dc2fd18da0f7b816bccadaeaa6f838.zip
sys-kernel/git-sources: add 6.8_rc6
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.8_rc6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 5b53947fdec0..c3d7dffdac4a 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-6.8-rc2.patch 43792863 BLAKE2B 7e5c5d3255d79d6318d115948d9994bbf96bd3
DIST patch-6.8-rc3.patch 44394710 BLAKE2B 626c9569dbc8ff077f5dedd8cf01553f0f9261b28407eaa08c4cf502aaf529441bea97c2c6ae1c01654a9b78feb77be32168a4dd082643b079b1c6379222f70e SHA512 255c0700bb24a3aea781c40a96e48a28583f6266940b4127af93e893361fa7e9a9ab5fdd435648de56d9c18bf06ce5a73cd8013a3c3f20c55f470fdeeca4e6b0
DIST patch-6.8-rc4.patch 44748761 BLAKE2B da6da63a288680039ea72412fad9c51cd0dcabcfec0920a1c82b046c6c616c99a7d602fbe99702817a7216ba502edf230707e3724a1b7667cd6530808d5e0f42 SHA512 b41bd3e7f74863350feb1213ef132069ba20a84762e7d8228271b7da311411536901dac287c71df8393ce60646f800ad7668b22ffeb9f6cebae15698bf3ddb0c
DIST patch-6.8-rc5.patch 45206799 BLAKE2B 629c0a1abd3e41b0f9e8b8c0ddcad75526948872b29371dba16f94e00a846c1c4b811c41446a7d686a533b858d20d66138d26d444a4021976bbcc0108cc17a66 SHA512 e693b249300093cb300445e102747e97fa84a2ffe989b0684aed83573357e805640b0442272be5e064899ce91b82b8917cfe5f1350cac6d2c3287959276b7c8a
+DIST patch-6.8-rc6.patch 45546090 BLAKE2B a9775d50d71233a6f2c24236e12a6cfcf8b1439f5fed8fbaa89bb45150a7b08cea8e6a37e6eb9a72e1321239d5d3277388f876256fcbc6df4b4b32f057125762 SHA512 a5434e310131c5db6c8a40e4fae665f000db68073a05f63e66afd9abbbaf5c3fefc72574dc71e6b60e2641b149ef68337fcb882e898d5aff047b1f631052b094
diff --git a/sys-kernel/git-sources/git-sources-6.8_rc6.ebuild b/sys-kernel/git-sources/git-sources-6.8_rc6.ebuild
new file mode 100644
index 000000000000..ca760a458b08
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.8_rc6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.7"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}