summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2018-01-23 23:05:40 +0100
committerAgostino Sarubbo <ago@gentoo.org>2018-01-23 23:05:40 +0100
commit6d569aab65d1fac95424355aaff8ac890345a1fb (patch)
tree1909e472a644e78595edbcd16d8df41b7316704b /sys-kernel/git-sources
parentsys-kernel/vanilla-sources: Automated version bump to {4.1.49,4.4.113,4.9.78,... (diff)
downloadgentoo-6d569aab65d1fac95424355aaff8ac890345a1fb.tar.gz
gentoo-6d569aab65d1fac95424355aaff8ac890345a1fb.tar.bz2
gentoo-6d569aab65d1fac95424355aaff8ac890345a1fb.zip
sys-kernel/git-sources: Automated version bump to 4.15_rc9.
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.15_rc9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index a6068d5f86c8..923ce23cd860 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -7,3 +7,4 @@ DIST patch-4.15-rc5.patch 45928364 BLAKE2B 0e798993916680abae0ec40c4bc3128b4b79f
DIST patch-4.15-rc6.patch 46146258 BLAKE2B 7a71a6e995aaa104012bb8f2a6e728658a2961d511d5302e7c3de182ae104ea8eafbce2a7b3c7a342ae84cbdee26cf9306fe231b9b92268cc8ed3d7cf562f3f6 SHA512 b68965ef7b78ed9a0547d3a00432b0afaa8441a77412026c84d9b91b751f62d54cb263ec0ffc3547196038f0fe39bdcdfd1e7535776dc8f7a139528ea8ce3dcc
DIST patch-4.15-rc7.patch 46244792 BLAKE2B 80731383db15ebc6aac897b97fe1602ab161f04ca1f3811b47e699d5d50c5e96281672261770c0e8a80f3c0111f6b210104bc67478ccc00cb658cd7d42fb396b SHA512 fae57a83355d3ee0d1b3f07c1af89036f97cb22ab2135a5b57299efb451f3ef91dd8e3822928fb3ad44271508a1ea355771b0e9416d41d25c3888a5074281ade
DIST patch-4.15-rc8.patch 46486932 BLAKE2B 783cc4fa216d7591a7cf0713cb1aa285017f382c1f6f8c5ebb5a98a5627080854b0f081f7a4417d650c0591ef1878047ebc54cc8ce04763214e861abb74c343d SHA512 30fdd6ad1174f8e3e2b58b80c2796cda502a24153fbdd8852defac552800b4f7baf66c840ec5c3ef4095391b89e6a700e9e5f88e67a2663db4544ac986c2142c
+DIST patch-4.15-rc9.patch 46706278 BLAKE2B 67552561e9a9e4d8bd6e878f3779319414abdc587140d31388eace7d43f955982f1a49cc36948d5b67f3379d8e13e6a8237d2f3c714860d32f042f01a0c53f5f SHA512 2d54f54d2a7b8586f3d5e3f2fef7768a7c10440c5394c14d397fc6686c56d028c7a5a81bf0e4e5a89f41b7d7124c69d983f7d972accd1e7c18b3505a579e80a8
diff --git a/sys-kernel/git-sources/git-sources-4.15_rc9.ebuild b/sys-kernel/git-sources/git-sources-4.15_rc9.ebuild
new file mode 100644
index 000000000000..b525f064fb5d
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.15_rc9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.14"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}