summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-10-06 19:16:02 -0400
committerMike Pagano <mpagano@gentoo.org>2019-10-06 19:16:10 -0400
commitc5b36b791e01db0a515aeb24aed82ef9e68f66e9 (patch)
tree3dc84d817d47ae239318a771d723669b7befa15b /sys-kernel/git-sources
parentdev-util/meson-0.51.2: alpha stable, bug 695638 (diff)
downloadgentoo-c5b36b791e01db0a515aeb24aed82ef9e68f66e9.tar.gz
gentoo-c5b36b791e01db0a515aeb24aed82ef9e68f66e9.tar.bz2
gentoo-c5b36b791e01db0a515aeb24aed82ef9e68f66e9.zip
sys-kernel/git-sources: Linux patch 5.4-rc2
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.4_rc2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index d04c06d7da11..a048850fe179 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-5.3.tar.xz 108558876 BLAKE2B 0d08eed879d05734e4542f0c93823d43f8dc042a54ba5268064c4bbebd7a9d59c03abf3ad5dee8280e784ae148a3b0c56181eaf2d5b3c079b6fe9f5191544df6 SHA512 6b5edef47c319a3fa7f6c20a3e0903a5acd89ec75e32dc5f99adcb60c9fe118ea312722d9c3d27e2e3900afa2455afb86e83a8b6bb131009bc79ddbe6fb0595d
DIST patch-5.4-rc1.patch 64078480 BLAKE2B 98ed781b61c9e35e8f78939ca0d2ff93d4a1cbad835955226bedb2c12a9b74564cc09a89a6b26d8932b4d1c36f1c6c455faa185d7d2c7eca71b80c927d4cfcd4 SHA512 f9771a13b3179033cd015bfa243ce13acce6d62ace8cc3184182d72933afe6c2928c85cba325b75040e03948b8bdde494ca5bb2b54edc0bc08345ef3470b3d3f
+DIST patch-5.4-rc2.patch 64354864 BLAKE2B 864d97e1ed5986448fdb1bc8782e1be236b7023ea9273a0ea589591df79726ddcf26d4241f498b550304d2edfc473af6c73a66eb06e3bceb35f47343e49e83f6 SHA512 b0fd0861c636e49b4e97d0954f966f82d0b8de5e117fd8f2f30b8f92b2e0f93ced475b37272ea37de038cf87cfe70cf6f7e951ef1aa4ef0ed483986a3fab04ec
diff --git a/sys-kernel/git-sources/git-sources-5.4_rc2.ebuild b/sys-kernel/git-sources/git-sources-5.4_rc2.ebuild
new file mode 100644
index 000000000000..7f3937ff7927
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.4_rc2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.3"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}