summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-22 16:57:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-22 16:57:38 +0100
commitc6fce3a6d36b9df6bf87ef914fb899c9c97fd480 (patch)
tree9e6a5ddcc1ae1e3aab646c226119b7fc3a079ef4 /sys-kernel/linux-headers/linux-headers-5.1.ebuild
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-c6fce3a6d36b9df6bf87ef914fb899c9c97fd480.tar.gz
gentoo-c6fce3a6d36b9df6bf87ef914fb899c9c97fd480.tar.bz2
gentoo-c6fce3a6d36b9df6bf87ef914fb899c9c97fd480.zip
sys-kernel/linux-headers: bump up to 5.1
This is the first gentoo release where we don't use rip-headers.sh and use upstream tarball directly to provide us headers. It will increase time and temporary space to unpack a tarball but it should be comparable or smaller than other toolchain packages like gcc or glibc. It's a reasonable price not to maintain our header ripping tools. More maintainable solution would be for upstream to provide headers-dist Makefile target (and tarballs). Reported-by: jamesrutledge@earthlink.net Closes: https://bugs.gentoo.org/686892 Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-5.1.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-5.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-5.1.ebuild b/sys-kernel/linux-headers/linux-headers-5.1.ebuild
new file mode 100644
index 000000000000..fcf1ccad796d
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+ETYPE="headers"
+H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 cris frv hexagon hppa ia64 m32r m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 riscv s390 score sh sparc x86 xtensa"
+inherit kernel-2
+detect_version
+
+PATCH_VER="1"
+SRC_URI="${KERNEL_URI}
+ ${PATCH_VER:+mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.xz}
+ ${PATCH_VER:+https://dev.gentoo.org/~slyfox/distfiles/gentoo-headers-${PV}-${PATCH_VER}.tar.xz}
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="app-arch/xz-utils
+ dev-lang/perl"
+RDEPEND=""
+
+S=${WORKDIR}/linux-${PV}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_prepare() {
+ default
+
+ [[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}"/${PV}/*.patch
+}
+
+src_install() {
+ kernel-2_src_install
+
+ # hrm, build system sucks
+ find "${ED}" '(' -name '.install' -o -name '*.cmd' ')' -delete
+ find "${ED}" -depth -type d -delete 2>/dev/null
+}
+
+src_test() {
+ emake ARCH=$(tc-arch-kernel) headers_check
+}