summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-03-06 22:25:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-03-06 22:27:21 +0000
commitcacca881e5e63f3d12966a74a7b2277a8044e836 (patch)
tree862c200059cc23c528d5b02a909883d3bc917ca0 /sys-kernel/linux-headers
parentdev-python/cherrypy: Add 17.4.1 (diff)
downloadgentoo-cacca881e5e63f3d12966a74a7b2277a8044e836.tar.gz
gentoo-cacca881e5e63f3d12966a74a7b2277a8044e836.tar.bz2
gentoo-cacca881e5e63f3d12966a74a7b2277a8044e836.zip
sys-kernel/linux-headers: package arch/*/kernel/syscalls, bug #679630
Recut linux-headers tarball with fixed 'rip-headers.sh' in https://gitweb.gentoo.org/proj/toolchain/linux-headers-patches.git/commit/?id=b418143bc1bc69f4b0c7509f74e16f9302557e4c Fixes headers installation on alpha, hppa, ia64, m68k, mips, power, sh4, sparc. Reported-by: Jeroen Roovers Closes: https://bugs.gentoo.org/679630 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-kernel/linux-headers')
-rw-r--r--sys-kernel/linux-headers/Manifest1
-rw-r--r--sys-kernel/linux-headers/linux-headers-5.0-r1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-kernel/linux-headers/Manifest b/sys-kernel/linux-headers/Manifest
index 602c59a9cbf4..4f4e3c443f53 100644
--- a/sys-kernel/linux-headers/Manifest
+++ b/sys-kernel/linux-headers/Manifest
@@ -22,4 +22,5 @@ DIST gentoo-headers-base-4.19.tar.xz 7956220 BLAKE2B 5b6868188b6cb505556b8f30797
DIST gentoo-headers-base-4.20.tar.xz 8041716 BLAKE2B 09e95aedfd4288fb27ad6c1e4f53992d205e9402efb315a8c764a2836ba856c7ec3f509d30c21e656e1ca9fdeb4530d807a10e0a74e3510c8e90aa82b222bafe SHA512 705c0cf3244039ef319002f17ea702fa91673eac6bb6a790c8451cad1f16951328e1ca1e3d26043708fcdc78bfaa1ff065322947e23b41c4acb9ed2b8acba427
DIST gentoo-headers-base-4.4.tar.xz 3911752 BLAKE2B 5031ecd48b99cb0c9c35ca935fa6a62cc36c076bab193ec397fc0d543170f29c6d5a0827a2ea5517eb68fc838819cbe3e5abd125bb920992492369d5e5c1e7cb SHA512 1cd3de58ff790c3730bea38138c7a45ef95d04288c69ffeabebb884fab3add13bd9c99785ddd87a3ee467a0e1b1cdc457bbd28da349e7c178b4d2374c5fb78a3
DIST gentoo-headers-base-4.9.tar.xz 4052748 BLAKE2B e279954c56170fbfa4ebae8dade731825b3d5f0cd5d73a5b33cd93a9c8f5fa140e14edf0d5ac26a452fe8a61b16fdcc851f5329f56e4c8dcf4472a995de44c4c SHA512 a03418cfba7fa4531279d9122411af3e285e962506e8df9279fbbb27ae08a4e30725bd1cf03f48ad523f61f2889195e6c844fa4c7b4ef2f828baf47ef402abfa
+DIST gentoo-headers-base-5.0-bug-679630.tar.xz 8102772 BLAKE2B b5ee691936b704133373027618b8a281371ee9ebbf6166b33af427d733e48ba3a9ea3f2d7be370b76769d6cae9cff01727d519a21789fcd95cee14d8cb285bf0 SHA512 59ef893a397a75bc0a87653de79be3bfbe12a952b325a679a940b0f59ecc853b3ffbed9a8c7eced81a082c3ba4471c9429841b52d8c64c6d49c69f727314f192
DIST gentoo-headers-base-5.0.tar.xz 8077316 BLAKE2B 3ee8472bb6f57b3070f8e8efea98e581cac5be88cc1218c031e04949fb2d4f06a660dc5e968da5dbbdca8b9428700c9427b35c85d5ac53338490fca7dc0ff427 SHA512 dc02d569f3dc8c197aeacafe55582723626c7aa52144a671d13652e6fbd40a468088a644f0206d37a620fd34d306b424c0d0d96260c5241a497689f7ef8b9011
diff --git a/sys-kernel/linux-headers/linux-headers-5.0-r1.ebuild b/sys-kernel/linux-headers/linux-headers-5.0-r1.ebuild
new file mode 100644
index 000000000000..0becabe872d0
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-5.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+ETYPE="headers"
+H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 cris frv hexagon hppa ia64 m32r m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 riscv s390 score sh sparc x86 xtensa"
+inherit kernel-2
+detect_version
+
+PATCH_VER="1"
+SRC_URI="mirror://gentoo/gentoo-headers-base-${PV}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/gentoo-headers-base-${PV}-bug-679630.tar.xz
+ ${PATCH_VER:+mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.xz}
+ ${PATCH_VER:+https://dev.gentoo.org/~slyfox/distfiles/gentoo-headers-${PV}-${PATCH_VER}.tar.xz}
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="app-arch/xz-utils
+ dev-lang/perl"
+RDEPEND=""
+
+S=${WORKDIR}/gentoo-headers-base-${PV}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_prepare() {
+ default
+
+ [[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}"/${PV}/*.patch
+}
+
+src_install() {
+ kernel-2_src_install
+
+ # hrm, build system sucks
+ find "${ED}" '(' -name '.install' -o -name '*.cmd' ')' -delete
+ find "${ED}" -depth -type d -delete 2>/dev/null
+}
+
+src_test() {
+ # Make sure no uapi/ include paths are used by accident.
+ egrep -r \
+ -e '# *include.*["<]uapi/' \
+ "${D}" && die "#include uapi/xxx detected"
+
+ einfo "Possible unescaped attribute/type usage"
+ egrep -r \
+ -e '(^|[[:space:](])(asm|volatile|inline)[[:space:](]' \
+ -e '\<([us](8|16|32|64))\>' \
+ .
+
+ einfo "Missing linux/types.h include"
+ egrep -l -r -e '__[us](8|16|32|64)' "${ED}" | xargs grep -L linux/types.h
+
+ emake ARCH=$(tc-arch-kernel) headers_check
+}