summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-12-07 12:28:35 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-12-07 12:28:35 +0200
commit10fd2aa4c3ce6a8f08ab8e14b9ec1de3d20f2a42 (patch)
tree68d310ae7c54cfe4ad2634313f6ecf8e7242c6f0 /sys-kernel/pf-sources
parentapp-office/scribus: Drop 1.5.5_pre20190429 (diff)
downloadgentoo-10fd2aa4c3ce6a8f08ab8e14b9ec1de3d20f2a42.tar.gz
gentoo-10fd2aa4c3ce6a8f08ab8e14b9ec1de3d20f2a42.tar.bz2
gentoo-10fd2aa4c3ce6a8f08ab8e14b9ec1de3d20f2a42.zip
sys-kernel/pf-sources: bump to 5.4-pf2
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.4_p2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 731675eb3404..477240b81e9a 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -20,3 +20,4 @@ DIST pf-sources-5.3_p5.patch 1596810 BLAKE2B ba0229daedb6e883192fc3de569601bc228
DIST pf-sources-5.3_p6.patch 2032026 BLAKE2B 5384f2196b3799861e79ab223a1370f4049b86f0cc201d2ab09d31127e08fff3de0b2403693046b5f7a5f73750e12f027f30a5897ca6e457f0fac760bf0b8c6f SHA512 31b5e1d7bfe934a7733f81b663f8022b3c292acda3cef982ca4e56fee0a1df151e58c4a8e3af3d9a85927cac773add4492f5be369526308f665c3bafb629e936
DIST pf-sources-5.3_p8.patch 2445607 BLAKE2B d1aa017f43219f661d16e82f9f36ef5b526aad8492f0bb758abda6c1d2caf2d07ed98fd444819dbcc64718c41f0e90b4f18969cafcf02737f1893d92514a49d5 SHA512 033d92493b54fa8bb231f168357cf3b65a7b858e75e04c24a6e97d0dbced7baa8b49cdaec11e4e4b3f2eb44de80a33780511785827dab0893dc1721d47085483
DIST pf-sources-5.4_p1.patch 258131 BLAKE2B 23305be06df369a9bd7efdc1ab1c79bcbe6c1d0eed2ed99102d71e32eb7588548211a9587d0a12b2dac0aa8e99fa996d535b84a70e6f53078dc2228fbc87f102 SHA512 71ce2ca76dc2a89d93e5bdd9feea95f02dbef6192fcd6fb3e7d1136b826114b1b2b359d387d6343b40c4e253ef2f6c55399242f1abec50ca554de5928dd5eda1
+DIST pf-sources-5.4_p2.patch 444667 BLAKE2B 970e27405a2bcfd206b7c4d2852c1329b9197cd14c4ad1bdcde0d5a36af41efe26ffec26469150da224c55cae7bc31c726a2ce0c93f723527423c5346d477367 SHA512 3f8ec934c71d9541a621bdff7c6db247e91027e83e0c0afcb08a6f7a0e4bf9c7667e4ad4a2bc7dd1aa7bb95f23ebe4d1ba818fd8ee24bb6cbf4e8e80a9ce150c
diff --git a/sys-kernel/pf-sources/pf-sources-5.4_p2.ebuild b/sys-kernel/pf-sources/pf-sources-5.4_p2.ebuild
new file mode 100644
index 000000000000..f95b603d66f4
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.4_p2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+ETYPE="sources"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+
+IUSE=""
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# No reason to bump this number unless something new gets included in genpatches,
+# in that case we can manually remove the linux kernel patches from genpatches.
+K_GENPATCHES_VER="1"
+
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security crew
+K_SECURITY_UNSUPPORTED="1"
+
+K_USEPV="yes"
+
+# We want the very basic patches from gentoo-sources, experimental patch
+# is already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+UNIPATCH_STRICTORDER="yes"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+
+PF_URI="https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch"
+SRC_URI="
+ ${KERNEL_URI}
+ ${PF_URI}
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz
+"
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+PATCHES=(
+ "${DISTDIR}/${P}.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}