summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-05-24 09:09:13 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-05-24 09:21:36 +0300
commit185d76cd383202cfd5827d1668b432c0f3e11feb (patch)
treee86623173b153fe5e1355f88961d852963e07f1a /sys-kernel/pf-sources
parentvirtual/perl-Unicode-Collate: Stabilize 1.290.0-r1 ppc64, #791541 (diff)
downloadgentoo-185d76cd383202cfd5827d1668b432c0f3e11feb.tar.gz
gentoo-185d76cd383202cfd5827d1668b432c0f3e11feb.tar.bz2
gentoo-185d76cd383202cfd5827d1668b432c0f3e11feb.zip
sys-kernel/pf-sources: bump to 5.12-pf3
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.12_p3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 833e87cf54c9..6c1ea3e05599 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -25,4 +25,5 @@ DIST pf-sources-5.11_p7.patch 5538351 BLAKE2B 112f27ae4c640b5398dea06eb85b3f8851
DIST pf-sources-5.11_p8.patch 5688583 BLAKE2B 5d845677efd1d6ac95282d24223c7aa26d33ea74670b37184fda20dded42b5de1c4b4fd06f29afb12c8fd3372feb208b7d655c1dba3b60cfd1f4dc5cecfe5116 SHA512 62105aa308543ae5bb2e79be77dd77f3d4d3430669423c6e9e528acb114edf3b3a3cdcc2371ea566a6a51dbc16ebfba64187dabf485a96dea7c0127162173675
DIST pf-sources-5.12_p1.patch 2785321 BLAKE2B 6010dcc736c6e068cb5aed9df790df6795f8b85f4169b9b6b66eb020f0e1821cd29630f421842c172f52fb41e4ac94f1671d506ec3f72f0bc883adbadd258302 SHA512 a861f3f96205de0c86a506bfd470116eeaabc8ec574e1940572abdfe166e16539f2fe874af5a0ea234741e5385e88491a49ba390a5493efc2fcc0c0283b43aa6
DIST pf-sources-5.12_p2.patch 4252808 BLAKE2B 2c23009ba31caa7f5e6268d854af2bb2f9db2831a67cb34ef535fe1914d913f057f514aa8ce7c1a8a63374498c56d9bcce0662ed4ec3a888e2e7518b339196c1 SHA512 e2da600deeea7e16667bd0c9e0be9349f47441a4d9c2f06f66fb4f2a78c1b2c596a502cc35c6d9aea3ffcdb26461299f3446b5bb5a9b88b059806eb4db80d2b2
+DIST pf-sources-5.12_p3.patch 4818489 BLAKE2B f2d729477ebe5016889de4d216e7ae824d1e4f8401129679d527c42fa1189b1e473711c77a8cb14de84bad9abbbdd2fc0ee3fa82dda64133c1af0ac42593a32a SHA512 6663710d313585ea279a86370d0e6c12e892abc6cb0c2481e81b70abfe427b0ec247d672ffa31587365b474efb2041c53ac99e39737bdc1529e3f1d9688bfe21
DIST pf-sources-5.9_p7.patch 3027972 BLAKE2B 9247ea63b30f9d42d79303b73a900d468a71e703333932f7f15ae697cdba52c46358297023e037226c219fad5df912fb5d21e6f4b7190556ca799fa84924480e SHA512 c69e14f59bf98944b3329c65b7e2c271d74a756bc8c890130bf3cc68b4b96d31f1c33c4edb128580fcaefeb6e42dd04b1eb3d7f071b2d58bc764d26322bda8cd
diff --git a/sys-kernel/pf-sources/pf-sources-5.12_p3.ebuild b/sys-kernel/pf-sources/pf-sources-5.12_p3.ebuild
new file mode 100644
index 000000000000..fed5b00b686c
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.12_p3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+SHPV="${PV/_p*/}"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${SHPV}...v${SHPV}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${SHPV}-${K_GENPATCHES_VER}.extras.tar.xz
+ https://raw.githubusercontent.com/GKernelCI/linux-patches/${SHPV}/5020_BMQ-and-PDS-io-scheduler-v${SHPV}-r0.patch
+ https://raw.githubusercontent.com/GKernelCI/linux-patches/${SHPV}/5021_BMQ-and-PDS-gentoo-defaults-v${SHPV}-r0.patch"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch"
+ "${DISTDIR}/5020_BMQ-and-PDS-io-scheduler-v${SHPV}-r0.patch"
+ "${DISTDIR}/5021_BMQ-and-PDS-gentoo-defaults-v${SHPV}-r0.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ # kernel-2_src_prepare doesn't apply PATCHES().
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ optfeature "userspace KSM helper" sys-process/uksmd
+}