summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2015-10-01 00:12:11 -0400
committerRichard Yao <ryao@gentoo.org>2015-10-01 00:29:48 -0400
commit735cf46fa78ec87d35db9a6eb1256b3489d89d29 (patch)
tree8f9c04c54b8f934a80474234cf2868a0ca51de61 /sys-kernel/spl/spl-9999.ebuild
parentsys-block/fio: delete wrong arch USE flag checking (diff)
downloadgentoo-735cf46fa78ec87d35db9a6eb1256b3489d89d29.tar.gz
gentoo-735cf46fa78ec87d35db9a6eb1256b3489d89d29.tar.bz2
gentoo-735cf46fa78ec87d35db9a6eb1256b3489d89d29.zip
sys-fs/zfs and friends: bump to 0.6.5.2
Upstream release notes: https://github.com/zfsonlinux/zfs/releases/tag/zfs-0.6.5.2 Some additional improvements were made to the ebuilds in this bump. 1. The incorrect requirement on BLK_DEV_LOOP was removed from sys-fs/zfs-kmod in favor of a cups ebuild style warning in sys-fs/zfs when BLK_DEV_LOOP is not avaliable and the test suite has been installed. 2. The regression where we remove the dracut module has been fixed. 3. The failure to migrate users to the zfs-zed script from the zed script has been fixed. 4. The 9999 ebuilds have been synchronized with the 0.6.5.2 ebuilds. 5. The sys-fs/zfs-kmod-0.6.5 has been removed due to the regression that prompted sys-fs/zfs-kmod-0.6.5-r1. Package-Manager: portage-2.2.20.1 Signed-off-by: Richard Yao <ryao@gentoo.org>
Diffstat (limited to 'sys-kernel/spl/spl-9999.ebuild')
-rw-r--r--sys-kernel/spl/spl-9999.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/sys-kernel/spl/spl-9999.ebuild b/sys-kernel/spl/spl-9999.ebuild
index 03171e038b67..e9236e5cae5d 100644
--- a/sys-kernel/spl/spl-9999.ebuild
+++ b/sys-kernel/spl/spl-9999.ebuild
@@ -12,9 +12,8 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/zfsonlinux/${PN}.git"
else
inherit eutils versionator
- MY_PV=$(replace_version_separator 3 '-')
- SRC_URI="https://github.com/zfsonlinux/${PN}/archive/${PN}-${MY_PV}.tar.gz"
- S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
+ SRC_URI="https://github.com/zfsonlinux/${PN}/archive/${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${P}"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
fi
@@ -46,7 +45,6 @@ pkg_setup() {
KALLSYMS
!PAX_KERNEXEC_PLUGIN_METHOD_OR
!PAX_SIZE_OVERFLOW
- !PAX_RANDKSTACK
ZLIB_DEFLATE
ZLIB_INFLATE
"
@@ -57,10 +55,10 @@ pkg_setup() {
!DEBUG_INFO_REDUCED
"
- kernel_is ge 2 6 26 || die "Linux 2.6.26 or newer required"
+ kernel_is ge 2 6 32 || die "Linux 2.6.32 or newer required"
[ ${PV} != "9999" ] && \
- { kernel_is le 3 16 || die "Linux 3.16 is the latest supported version."; }
+ { kernel_is le 4 3 || die "Linux 4.3 is the latest supported version."; }
check_extra_config
}
@@ -92,7 +90,6 @@ src_configure() {
--with-linux="${KV_DIR}"
--with-linux-obj="${KV_OUT_DIR}"
$(use_enable debug)
- $(use_enable debug-log)
)
autotools-utils_src_configure
}