summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-02 08:59:00 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-02 20:22:39 +0200
commitb5253cf5439a0f34d856fad88fbdf7c670485e19 (patch)
treed794db7652d192a30c69cc4cfd7ce818a9fe2dfe /sys-kernel/vanilla-kernel
parentsys-kernel/vanilla-kernel: Remove old (diff)
downloadgentoo-b5253cf5439a0f34d856fad88fbdf7c670485e19.tar.gz
gentoo-b5253cf5439a0f34d856fad88fbdf7c670485e19.tar.bz2
gentoo-b5253cf5439a0f34d856fad88fbdf7c670485e19.zip
sys-kernel/vanilla-kernel: Bump to 4.19.113
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel/vanilla-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest1
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-4.19.113.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index dc992905e746..58d2918398c4 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -1,4 +1,5 @@
DIST linux-4.19.112.tar.xz 103425652 BLAKE2B d2b2e4b4e89d47d7158e438de3f7912f7bbf4623423b90e69c76138717d1d1a62599372d13fb91476d01c79661241a28db3682bec98955bcbbb83004303d21b7 SHA512 1e52a26d6f19c6659d3c2d23d492cb3775036f2a75e53db442c50f2c48cad2a2509fdf48ff7a96eb78750e2f8b540f7e55055a4799d060a287147b0b55931325
+DIST linux-4.19.113.tar.xz 103430528 BLAKE2B 6eefb598da59a54d2f73e17d13b48a1398ed57cbc25b0c80785fa34727e97f618bd7c99e1c3e15a93aa0cb0c6da63f623f72341a272100203772b05c5bdbe3f0 SHA512 9c5ab7bde99ec8c622c0fe5141ce679244fb4970a92ef5f3d839abdd00af24aaf2d2733f78d26ca939e598843a1de316de0d8e96f7ee7689dbb2a62e8c348057
DIST linux-4.19.85-arch1.i686.config 222183 BLAKE2B 03eac77940db0ee6b4f2a006edc600ef34141bbca849f5be4de9b961301a8fc987da6d0e21344aa5d80c29bb7793d56cf5441abb6c8e4057d94e2601c174c1be SHA512 6bd45c9dfd96b1afb8c1ca1ca72722baee6c91894e454d7af937de02242d3bb9d3b6870f5976aa96245c753c6bc1ac637a6356125b0d4c596aadef643b8c3d8d
DIST linux-4.19.92-arch1.amd64.config 222487 BLAKE2B a658d80d85525287a1df9053ca2ddfe423ab423bcc3b9ea8bd9cda65cc7ffa4b1be782c48c867c13e46070af4016f446860f5cf71351f239da1eff6c45a5aa6a SHA512 a5658c8e8464516dffd6f624344e739784cb315d334b2c5105bd5d16022b6366ad4ec00d3692a7b78e2458514175522bc85e834bf19593feff6363b616860258
DIST linux-5.4.24.arch1.amd64.config 241418 BLAKE2B b24fbeb04cb63b5f0ec7ea935b21302aec92552f1a8108c204f8529803d5eb23dc6124529ca0f9fc394af051b0d3725698fb5df95d6af25274cb51146e3c052b SHA512 d180f3cea5c9c357d482d8533dec7e641b782f501c15f749a5a5347fe737fab93a43a95e12391fcbe3d93a90d673c91b890cb66d219a8f8247074d222959e9cd
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.113.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.113.ebuild
new file mode 100644
index 000000000000..17bfa6ee759e
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-4.19.113.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build
+
+MY_P=linux-${PV}
+# https://git.archlinux.org/svntogit/packages.git/log/trunk/config?h=packages/linux-lts
+AMD64_CONFIG_VER=4.19.92-arch1
+AMD64_CONFIG_HASH=bf97de6a2e405659aaad4c251b7f0bb48d5ed3c9
+# https://git.archlinux32.org/packages/log/core/linux-lts/config
+I686_CONFIG_VER=4.19.85-arch1
+I686_CONFIG_HASH=1f0345e2983d2edd55b401cb5a87fdf365a4192c
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ amd64? (
+ https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux-lts&id=${AMD64_CONFIG_HASH}
+ -> linux-${AMD64_CONFIG_VER}.amd64.config
+ )
+ x86? (
+ https://git.archlinux32.org/packages/plain/core/linux-lts/config?id=${I686_CONFIG_HASH}
+ -> linux-${I686_CONFIG_VER}.i686.config
+ )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ !sys-kernel/vanilla-kernel-bin:${SLOT}"
+
+src_prepare() {
+ default
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
+ ;;
+ x86)
+ cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local config_tweaks=(
+ # shove arch under the carpet!
+ -e 's:^CONFIG_DEFAULT_HOSTNAME=:&"gentoo":'
+ # we do support x32
+ -e '/CONFIG_X86_X32/s:.*:CONFIG_X86_X32=y:'
+ # disable signatures
+ -e '/CONFIG_MODULE_SIG/d'
+ -e '/CONFIG_SECURITY_LOCKDOWN/d'
+ # disable compression to allow stripping
+ -e '/CONFIG_MODULE_COMPRESS/d'
+ # disable gcc plugins to unbreak distcc
+ -e '/CONFIG_GCC_PLUGIN_STRUCTLEAK/d'
+ )
+ sed -i "${config_tweaks[@]}" .config || die
+}