summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-kernel/xbox-sources
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-kernel/xbox-sources')
-rw-r--r--sys-kernel/xbox-sources/Manifest3
-rw-r--r--sys-kernel/xbox-sources/metadata.xml11
-rw-r--r--sys-kernel/xbox-sources/xbox-sources-2.6.16.26.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/xbox-sources/Manifest b/sys-kernel/xbox-sources/Manifest
new file mode 100644
index 000000000000..df26e621b5bb
--- /dev/null
+++ b/sys-kernel/xbox-sources/Manifest
@@ -0,0 +1,3 @@
+DIST linux-2.6.16-xbox.patch.gz 114525 SHA256 c8c3bd4b506f2c5a534d43efa6121e701aa5268a63ce4f35855c7a00b4d4f5f7 SHA512 003fd833a5fe6f96f6a3ac187cfd5083486ffa3472cb73f118b33b74a0b236a15f1bee8b28f7a08fed508ea57d78717f5834de8b77847a07c3a14e8b8ca9d076 WHIRLPOOL 1c8eedfa5263a9751e44c14239c9f9e6220e485182702c9f965297cd996edaa7d22a85513b0fc79637f2d9d33c203e7834c9752f6598e07dfc00ac5d482bbd79
+DIST linux-2.6.16.tar.xz 33178492 SHA256 6851eabcdd9da0d79f6d7c62da941547da963fa916c3d30ac5e8d70367cdc75a SHA512 7df52017beeedb9c0abe2f3ea0054141153d10acdd20935b60f357ee795c04f4235477776dbe6b81f34e33f4451325202c5f6d41201de299e69b653cbef7c9a1 WHIRLPOOL 3ec1f4cfd265b1b177d65959d24b89781af471f8a6b7be616ed8f88e7d531e2d25b6e7a8626bdb4ada5844843a912bbef37d9a5d25e283811cdc7803351fdb50
+DIST patch-2.6.16.26.xz 58504 SHA256 b280b662a3bc92e11b28a825582d7046d8064c30c342707e76f7f0c5a3ab7715 SHA512 5c088557e788a25aa6dfe4b60e80af0cb0a1cb09e5d17fcdfd7912dadd7810381425931ac42de35e13c51b8349cf5c134dbb2feb5726131725bae99d35caa4ce WHIRLPOOL f1383cac82ce5dd4a6767bae37ae3add551ccb3cae1e8583585cb00e276ec6dfdab7cec5d6f55e8cdc304801dbd8548569572914964c67c7cc2d147a667ea767
diff --git a/sys-kernel/xbox-sources/metadata.xml b/sys-kernel/xbox-sources/metadata.xml
new file mode 100644
index 000000000000..413f9bdcef93
--- /dev/null
+++ b/sys-kernel/xbox-sources/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kernel</herd>
+ <herd>xbox</herd>
+ <longdescription>Full sources for the Xbox Linux kernel</longdescription>
+ <upstream>
+ <remote-id type="cpe">cpe:/o:linux:linux_kernel</remote-id>
+ <remote-id type="sourceforge">xbox-linux</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-kernel/xbox-sources/xbox-sources-2.6.16.26.ebuild b/sys-kernel/xbox-sources/xbox-sources-2.6.16.26.ebuild
new file mode 100644
index 000000000000..63d24d5b7d87
--- /dev/null
+++ b/sys-kernel/xbox-sources/xbox-sources-2.6.16.26.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+ETYPE='sources'
+K_SECURITY_UNSUPPORTED="1"
+inherit kernel-2
+detect_arch
+detect_version
+
+# version of gentoo patchset
+XBOX_PATCHES=linux-2.6.16-xbox.patch.gz
+
+KEYWORDS="~x86 -*"
+UNIPATCH_LIST="
+ ${ARCH_PATCH}
+ ${DISTDIR}/${XBOX_PATCHES}"
+DESCRIPTION="Full sources for the Xbox Linux kernel"
+SRC_URI="${KERNEL_URI}
+ ${ARCH_URI}
+ mirror://sourceforge/xbox-linux/${XBOX_PATCHES}"