summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-02-19 14:27:42 -0500
committerMike Pagano <mpagano@gentoo.org>2021-02-19 14:27:42 -0500
commit0bd2e06d869142ffffb4a87e4dd8f0d5d5d46856 (patch)
tree5b8f8a183c6e6bb2851584c297801edfcda913f4 /sys-kernel
parentdev-ruby/GeoRuby: Remove old (diff)
downloadgentoo-0bd2e06d869142ffffb4a87e4dd8f0d5d5d46856.tar.gz
gentoo-0bd2e06d869142ffffb4a87e4dd8f0d5d5d46856.tar.bz2
gentoo-0bd2e06d869142ffffb4a87e4dd8f0d5d5d46856.zip
sys-kernel/linux-docs: Fix compilation issue due to /bin/sh
Closes: https://bugs.gentoo.org/771213 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-docs/linux-docs-5.10.17.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-5.10.17.ebuild b/sys-kernel/linux-docs/linux-docs-5.10.17.ebuild
index ae8acc496808..bd48e869dd87 100644
--- a/sys-kernel/linux-docs/linux-docs-5.10.17.ebuild
+++ b/sys-kernel/linux-docs/linux-docs-5.10.17.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+PYTHON_COMPAT=( python3_{8,9} )
+inherit python-any-r1 toolchain-funcs
MY_PV="$(ver_cut 1-2)"
MY_P=linux-${MY_PV}
@@ -18,17 +19,27 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE=""
-BDEPEND="media-libs/fontconfig"
-DEPEND="dev-python/sphinx"
+
+DEPEND=""
RDEPEND=""
+BDEPEND="${PYTHON_DEPS}
+ dev-python/sphinx
+ dev-python/sphinx_rtd_theme
+ media-libs/fontconfig"
+
+src_prepare() {
+ default
+ # Fix the Python shebangs.
+ python_fix_shebang "${S}/Documentation/sphinx/"
+}
src_compile() {
local ARCH=$(tc-arch-kernel)
unset KBUILD_OUTPUT
+ HTML_DOCS=( Documentation/output/. )
emake htmldocs
}
src_install() {
- HTML_DOCS=( Documentation/output/. )
einstalldocs
}