summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-09-16 17:34:38 -0400
committerMike Pagano <mpagano@gentoo.org>2018-09-16 17:34:50 -0400
commit34035580258024976e1058333fd27f31a5f76458 (patch)
tree7ab34894eed4712770d4354933f878e966e4be8b /sys-kernel
parentdev-python/bytecodeassembler: EAPI7, fix HOMEPAGE, minor improvements. (diff)
downloadgentoo-34035580258024976e1058333fd27f31a5f76458.tar.gz
gentoo-34035580258024976e1058333fd27f31a5f76458.tar.bz2
gentoo-34035580258024976e1058333fd27f31a5f76458.zip
sys-kernel/git-sources: Linux patch 4.19-rc4
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.19_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 74756955eddc..3dd6343eeca8 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-4.18.tar.xz 101781564 BLAKE2B 138bdc49dc8871e5566b5e23a9e5ed0e68fff48
DIST patch-4.19-rc1.patch 38084340 BLAKE2B bda832e116f74e04485b1d253b0a01a4838b62725f572009c7be22a7f1323f1910bb7c75793e768404ec5fbc2f48be038523e440fb365aaed4d318e2c8616be7 SHA512 84c2fc3869db3f45b7cc6bbd0d9830c8d5b4a921a887b7b2ed39b332c384ca276b083205d0adee0e2f9ad42650961db642979c57250638126363366629e3fbdc
DIST patch-4.19-rc2.patch 38326203 BLAKE2B 7cb9f6a80591dcecc13b22d9990d2ea03218ff6f1ca1d72e203bb7d98e8376b1da36f0ac5f834dd1de16c4e4950b0231db9c84af3852494c6a27ca0024f0ed9a SHA512 17473b20591cbecb00ab6b3e882a3e039b75a8fc32b776a71f1d02d6179d98f0cd4977de45d4c624b955b7951d4a36f32fb191ab1fffe92798f01c428676cce2
DIST patch-4.19-rc3.patch 38635039 BLAKE2B c6f5840a1483c0a97b284f038f965d74b268c3f2eb7c60d7c0b6136e8d996482127653a000135af32a9c2d69d42bea571acbe88d1a0ee42be38fee07853aa121 SHA512 ba836197b02bc25af6201c819efc3266a8e12214161203b82aac488c28f939065b8b7887c035cfe3ca18f0cbec5b833bb9623277686b05228002f9f0f2986a8c
+DIST patch-4.19-rc4.patch 38932487 BLAKE2B fc07f52bc086f9d4f52e1ebd996ac1a2cdfce8130edb2f26251863b2f4a78f0f55c82a7f7aaf744db8b40e1ad4ab8aa3f16f3934960c46a06edb5967382d5d96 SHA512 8d61ff650a479676310db533d0d0625c5304caf777d924199b91a7b94d4840d9088def4a9b184e493a083a03ed20853811a5ee45b4f5074efd79129d6b3fb7b1
diff --git a/sys-kernel/git-sources/git-sources-4.19_rc4.ebuild b/sys-kernel/git-sources/git-sources-4.19_rc4.ebuild
new file mode 100644
index 000000000000..d03b0ba0d27b
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.19_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.18"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}