summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-03-14 18:09:28 -0400
committerMike Pagano <mpagano@gentoo.org>2021-03-14 18:09:28 -0400
commit46584b236e4a11835cf972d22dcfe49f88f0ab10 (patch)
tree5b1ad6f94104bed2809c7491ea626a2878010d31 /sys-kernel
parentdev-ml/ocaml-ctypes: Stabilize 0.17.1 arm, #775782 (diff)
downloadgentoo-46584b236e4a11835cf972d22dcfe49f88f0ab10.tar.gz
gentoo-46584b236e4a11835cf972d22dcfe49f88f0ab10.tar.bz2
gentoo-46584b236e4a11835cf972d22dcfe49f88f0ab10.zip
sys-kernel/git-sources: Linux patch 5.12-rc3
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.12_rc3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 5bdb22f673f4..485bf519726d 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-5.11.tar.xz 117619104 BLAKE2B 81300c27bd5476387a83123aaeb4163c73eb61e9245806c23660cb5e6a4fa88ffc9def027031335fa0270fc4080506cd415990014364e3a98b9d2e8c58a29524 SHA512 a567ec133018bb5ec00c60281479b466c26e02137a93a9c690e83997947df02b6fd94e76e8df748f6d70ceb58a19bacc3b1467de10b7a1fad2763db32b3f1330
DIST patch-5.12-rc2.patch 38085886 BLAKE2B 936f291c72b0befa6daf3f3070247e94a2e5ac14857e5a4053f99b5b4edbf1093f47b01a4bfe2884bf1461f0f67873b48b3d352493909d4377a766a5b05702a3 SHA512 4f92e162d8869045dabf245ab3e1a1518291b9d7fd5c27039dc97c656a15da1445bc9786746ba186180898abe8edcb52bab6e122119762e283722b8be19b5254
+DIST patch-5.12-rc3.patch 38689504 BLAKE2B 25962d05cfd031ea45347f339da8dd206c38ee16c78fd5ff39edb564474b11d4321e450904f9db491f62bb6002e338ef3136327d656c028eaae6f8a3b9207229 SHA512 585a883af66641247e3a44ca56788dc5afe5a2f3a8bd0d9aaabba0324cbbbd4dffdad0d9bc65e30f77903c870985bfbfe1a3283cc709b92417f89d2c94ab8f16
diff --git a/sys-kernel/git-sources/git-sources-5.12_rc3.ebuild b/sys-kernel/git-sources/git-sources-5.12_rc3.ebuild
new file mode 100644
index 000000000000..841923d20fb6
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.12_rc3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.11"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}