summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-09-10 06:33:07 -0400
committerMike Pagano <mpagano@gentoo.org>2018-09-10 06:33:16 -0400
commit61790c0a4afaf11e1051a8758250f643ad3b4788 (patch)
tree8401348059bafe110ba9798687896c66abbdf345 /sys-kernel
parentsys-apps/man-db: fix build with berkdb (diff)
downloadgentoo-61790c0a4afaf11e1051a8758250f643ad3b4788.tar.gz
gentoo-61790c0a4afaf11e1051a8758250f643ad3b4788.tar.bz2
gentoo-61790c0a4afaf11e1051a8758250f643ad3b4788.zip
sys-kernel/git-sources: Linux patch 4.19-rc3
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.19_rc3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index ea543cb85007..74756955eddc 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,3 +1,4 @@
DIST linux-4.18.tar.xz 101781564 BLAKE2B 138bdc49dc8871e5566b5e23a9e5ed0e68fff480a7a04fc659a9efe2d4bcc778ac01368a32bc5d1dbde870102ce7294b9d315f81c4e6e762ee781135e83033f2 SHA512 950eb85ac743b291afe9f21cd174d823e25f11883ee62cecfbfff8fe8c5672aae707654b1b8f29a133b1f2e3529e63b9f7fba4c45d6dacccc8000b3a9a9ae038
DIST patch-4.19-rc1.patch 38084340 BLAKE2B bda832e116f74e04485b1d253b0a01a4838b62725f572009c7be22a7f1323f1910bb7c75793e768404ec5fbc2f48be038523e440fb365aaed4d318e2c8616be7 SHA512 84c2fc3869db3f45b7cc6bbd0d9830c8d5b4a921a887b7b2ed39b332c384ca276b083205d0adee0e2f9ad42650961db642979c57250638126363366629e3fbdc
DIST patch-4.19-rc2.patch 38326203 BLAKE2B 7cb9f6a80591dcecc13b22d9990d2ea03218ff6f1ca1d72e203bb7d98e8376b1da36f0ac5f834dd1de16c4e4950b0231db9c84af3852494c6a27ca0024f0ed9a SHA512 17473b20591cbecb00ab6b3e882a3e039b75a8fc32b776a71f1d02d6179d98f0cd4977de45d4c624b955b7951d4a36f32fb191ab1fffe92798f01c428676cce2
+DIST patch-4.19-rc3.patch 38635039 BLAKE2B c6f5840a1483c0a97b284f038f965d74b268c3f2eb7c60d7c0b6136e8d996482127653a000135af32a9c2d69d42bea571acbe88d1a0ee42be38fee07853aa121 SHA512 ba836197b02bc25af6201c819efc3266a8e12214161203b82aac488c28f939065b8b7887c035cfe3ca18f0cbec5b833bb9623277686b05228002f9f0f2986a8c
diff --git a/sys-kernel/git-sources/git-sources-4.19_rc3.ebuild b/sys-kernel/git-sources/git-sources-4.19_rc3.ebuild
new file mode 100644
index 000000000000..d03b0ba0d27b
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.19_rc3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.18"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}