summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2018-05-07 10:39:30 +0200
committerAgostino Sarubbo <ago@gentoo.org>2018-05-07 10:39:30 +0200
commit7a7ceeb27dc072db57c4f9eb6cbcfc6bd0d30ffc (patch)
tree5dc7a9a443cd88694ae563107673df1342f97b5c /sys-kernel
parentgames-arcade/tuxpuck: Use pkg-config to find freetype (diff)
downloadgentoo-7a7ceeb27dc072db57c4f9eb6cbcfc6bd0d30ffc.tar.gz
gentoo-7a7ceeb27dc072db57c4f9eb6cbcfc6bd0d30ffc.tar.bz2
gentoo-7a7ceeb27dc072db57c4f9eb6cbcfc6bd0d30ffc.zip
sys-kernel/git-sources: Automated version bump to 4.17_rc4.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.17_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 0fb356d80712..f0ed0e96aeab 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-4.16.tar.xz 103020152 BLAKE2B c7f7b36280b74b2112a098733680e1e93c4f995
DIST patch-4.17-rc1.patch 76210575 BLAKE2B 8e523a01dd17b03f41314c2e0bd1392fb13123ed2f9ed35546acfbb18e1fdf1b51db52093115fc40a4172643dbecd414c988986118272111cdeeab2ed67f6c9b SHA512 b447657f4ee2bb7408268a1d8d29cf40c57b9b74e306b391f037e2c5be41bc40249389e19baed630fd5fef03a8fe80377f71aa93de6ab4909d04451e5b2bce1a
DIST patch-4.17-rc2.patch 76681837 BLAKE2B ffd1b51b4dc8f8532d332a58cd0115ba4b313a3280c7185caf93c23a7b5b8dea2b0546bb5c8ec405cd546ddb980d9e5e506148fe8c2c9490b35532393b9ed070 SHA512 6ebb9476f065796a8789cb2d16bb8525d3c1f0e81b7b501e36c13e6da9f7b5ce9112978ffa1a2196a399815c351d006535d9c9a34e8605a0c1405273beb289c9
DIST patch-4.17-rc3.patch 77049043 BLAKE2B 3c9b46367213c8ce7d510805a24743b2e92c32242f7f283cb79c723b58037c4d70980bf1f377a440c52e8c2e9f119227dd0116a04f5399bd7c6a1f2b091946a8 SHA512 9ae8ebc92b11bcc61555f2a6377979e1cca97e6b44d80c99165da0c8e9b3bbb0913ed9de58b74b80b99ddf7585a77ec4e9b659dc1e51772966d8d2d8f5d808c7
+DIST patch-4.17-rc4.patch 77311375 BLAKE2B 459f8b6b19473d4e5b837c6c4f8c0d08445b294f925cbcca450366a7ff51f5009cef32054521acd06255f98d2e693ba2cba5bac38e72b471d31388dd467172a6 SHA512 75ceeda7f8c1e717ffc3d52b7c30a97564b9e4bd1963be086cda3627c40a64a36950511315287dd1f7bbcc02a5ce5e53a26a7dc934125988f20300a24243d886
diff --git a/sys-kernel/git-sources/git-sources-4.17_rc4.ebuild b/sys-kernel/git-sources/git-sources-4.17_rc4.ebuild
new file mode 100644
index 000000000000..9c1348e1d5af
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.17_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.16"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}