summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-05-27 19:54:22 -0400
committerMike Pagano <mpagano@gentoo.org>2018-05-27 19:54:30 -0400
commit8fb1b86cb91807c800a490d00b70a5341c803754 (patch)
tree9c007f6757071d1ac8c5fa3ac9d711d99110be83 /sys-kernel
parentnet-p2p/transmission: update live ebuild (diff)
downloadgentoo-8fb1b86cb91807c800a490d00b70a5341c803754.tar.gz
gentoo-8fb1b86cb91807c800a490d00b70a5341c803754.tar.bz2
gentoo-8fb1b86cb91807c800a490d00b70a5341c803754.zip
sys-kernel/git-sources: Linux patch 4.17-rc7
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.17_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index b6c793968ac6..bd32bc69126d 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-4.17-rc3.patch 77049043 BLAKE2B 3c9b46367213c8ce7d510805a24743b2e92c3
DIST patch-4.17-rc4.patch 77311375 BLAKE2B 459f8b6b19473d4e5b837c6c4f8c0d08445b294f925cbcca450366a7ff51f5009cef32054521acd06255f98d2e693ba2cba5bac38e72b471d31388dd467172a6 SHA512 75ceeda7f8c1e717ffc3d52b7c30a97564b9e4bd1963be086cda3627c40a64a36950511315287dd1f7bbcc02a5ce5e53a26a7dc934125988f20300a24243d886
DIST patch-4.17-rc5.patch 77521265 BLAKE2B 6b484480cf896f109b2b2f93fe208f0a93fe3c759fc06df3d9ce2f6d1232910ba6f6e1c095f1bd293aa336510a42ecb4029006156db8be8c3a63b8d0bd17f324 SHA512 9dc5909ebc1d31dab402bbef68f679a41ee92845f4f2454680b5f8e53f659b0392f0475f62cd660eb3f081a75986e8fdc34fa17b61fa35f81c7a6770536afc58
DIST patch-4.17-rc6.patch 77746464 BLAKE2B 1f09f65007e3e68bc8c771f2eb44e3322e2da8682d5dfa74238bccb2648088e6b083685342ee5e17dd9926b68604bf98c757d974aebef2f49dcdce4fcda420db SHA512 ccf62eec146ad854990227821f4c08fbf58422342ddadfc1328cd6260045a353981c9f860a40aee44dbfe4840e998c065e1a5c1345c0849df719e1a3ee6114a0
+DIST patch-4.17-rc7.patch 78066488 BLAKE2B 84fe03f549b89a464dcfcaeb9cba9c6c43dce8f6a9de37841b2134e5fe4dc583b7f8c5ea3b651e60c42b63d2dfaa43fbbdbcac3be95ea4db2944ab2e6746eb5c SHA512 be6e5a0cab7ceb5adab4086b25ef536702b3829d8c39d06dae08f455d1f38e0987e8c80113a290ff1a86b8fc2110afe6ea17a5c68e216ad94880e102296a1171
diff --git a/sys-kernel/git-sources/git-sources-4.17_rc7.ebuild b/sys-kernel/git-sources/git-sources-4.17_rc7.ebuild
new file mode 100644
index 000000000000..c0dc94565fda
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.17_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.16"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}