summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-13 18:05:36 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-13 18:05:53 +0100
commitf08495ceaefac802a8433805373ad601af9ad6a4 (patch)
treed49a6e2b4d0dc5afef9555b1ca136ead3e460ffd /sys-kernel
parentvirtual/notification-daemon: improve KDE handling (diff)
downloadgentoo-f08495ceaefac802a8433805373ad601af9ad6a4.tar.gz
gentoo-f08495ceaefac802a8433805373ad601af9ad6a4.tar.bz2
gentoo-f08495ceaefac802a8433805373ad601af9ad6a4.zip
sys-kernel/linux-firmware: Add new snapshot
Gentoo-Bug: 596550 Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-firmware/Manifest1
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-20161005.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/sys-kernel/linux-firmware/Manifest b/sys-kernel/linux-firmware/Manifest
index 606d392b4567..14457fd51d82 100644
--- a/sys-kernel/linux-firmware/Manifest
+++ b/sys-kernel/linux-firmware/Manifest
@@ -3,3 +3,4 @@ DIST linux-firmware-20160223.tar.xz 35929392 SHA256 fde2f588fc0d2b7efa3b906a831e
DIST linux-firmware-20160331.tar.xz 35957140 SHA256 99ab767835006038e9efcc9d583b767c4a98091c35a6e2710f654e4fc2db7a45 SHA512 99694f336c4051d51f527399e225ee4a5842024d52f0d74204afd947ab5d0517c774e42519f469a1b653bc2ea026735bb83af5e495a8c2c5b5898ebe5d86cb40 WHIRLPOOL 17091f691577fa0976cb90cb6a60599155ff02afb95aacfa9c12228371c69d88750214b76f479cfdf55f36f7584a03c81158a61b1a593012e15db0ce8d740672
DIST linux-firmware-20160616.tar.xz 36089804 SHA256 216cd8680ab29368f2c206b3dbaa180e5f7331f64b016e0a674870f8abe668b5 SHA512 0a6c8aaea9a6bea5eb92a60499861d59e91b87ab44af4e1b7794539ae46ca6cc5a59ca945d4e4d376bdcf1820b32c66531459db7bfb95e97d343cf9a964f6f7e WHIRLPOOL 17df2ff0d701728c9815ee4e1be6548939fb9d3e54e55ae4caeb05b41b3a0921048a7c0a05f1e682c1a32c3344e1e7c0717fadb365b7717c95f96506f2e93a81
DIST linux-firmware-20160628.tar.xz 37855232 SHA256 02e22483b466a30284adfce1ec7189f7c2a18a4af2e747e0eb73227ce3bf466b SHA512 cf202ee5526f0a6af2341d7ec248b8eae380acda0bacd9c1b56ea5eeb9880ade2d10ff81b533e761233d54e3a8fa862d39795ab012878784f8a905bbefb3c1d1 WHIRLPOOL 29f4286cc3ab63bf0197d9c2d2e7bfeee7a5312b8ff594e178d81cdb511c253b33d6b00ca8767d57ac643b377618465e1e87a1227db86bd55a00d8999ed2acd4
+DIST linux-firmware-20161005.tar.xz 40838788 SHA256 4172e2febc8c075edcdb5d1977b56b7dbb3cf173967f7a4fd85d2791221b1912 SHA512 3926ef8fe471e5b51f92e490f8433c5fc44bb0c717c5b5fea4c5143d0247fbccaa063c5108efde04f18927c71ef55bbb0f2197f7fb2511a352098cb155d0bb23 WHIRLPOOL 9ab05165ae7f1597d2f7b3bb249282fb1ba34bbe315e004d039f10bf2981ebd5f9c64669498efa5bb8243164ae1842606eefe864bf61119c23c53e739a390e84
diff --git a/sys-kernel/linux-firmware/linux-firmware-20161005.ebuild b/sys-kernel/linux-firmware/linux-firmware-20161005.ebuild
new file mode 100644
index 000000000000..7b11e8b06d76
--- /dev/null
+++ b/sys-kernel/linux-firmware/linux-firmware-20161005.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit savedconfig
+
+if [[ ${PV} == 99999999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
+ KEYWORDS=""
+else
+ GIT_COMMIT="a179db97914da5e650c21ba8f9b0bae04a0f8a41"
+ SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-${GIT_COMMIT}.tar.xz -> ${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Linux firmware files"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git"
+
+LICENSE="GPL-1 GPL-2 GPL-3 BSD freedist"
+SLOT="0"
+IUSE="savedconfig"
+
+DEPEND=""
+RDEPEND="!savedconfig? (
+ !sys-firmware/alsa-firmware[alsa_cards_ca0132]
+ !sys-firmware/alsa-firmware[alsa_cards_korg1212]
+ !sys-firmware/alsa-firmware[alsa_cards_maestro3]
+ !sys-firmware/alsa-firmware[alsa_cards_sb16]
+ !sys-firmware/alsa-firmware[alsa_cards_ymfpci]
+ !media-tv/cx18-firmware
+ !<sys-firmware/ivtv-firmware-20080701-r1
+ !media-tv/linuxtv-dvb-firmware[dvb_cards_cx231xx]
+ !media-tv/linuxtv-dvb-firmware[dvb_cards_cx23885]
+ !media-tv/linuxtv-dvb-firmware[dvb_cards_usb-dib0700]
+ !net-dialup/ueagle-atm
+ !net-dialup/ueagle4-atm
+ !net-wireless/ar9271-firmware
+ !net-wireless/i2400m-fw
+ !net-wireless/libertas-firmware
+ !sys-firmware/rt61-firmware
+ !net-wireless/rt73-firmware
+ !net-wireless/rt2860-firmware
+ !net-wireless/rt2870-firmware
+ !sys-block/qla-fc-firmware
+ !sys-firmware/amd-ucode
+ !sys-firmware/iwl1000-ucode
+ !sys-firmware/iwl2000-ucode
+ !sys-firmware/iwl2030-ucode
+ !sys-firmware/iwl3945-ucode
+ !sys-firmware/iwl4965-ucode
+ !sys-firmware/iwl5000-ucode
+ !sys-firmware/iwl5150-ucode
+ !sys-firmware/iwl6000-ucode
+ !sys-firmware/iwl6005-ucode
+ !sys-firmware/iwl6030-ucode
+ !sys-firmware/iwl6050-ucode
+ !sys-firmware/iwl3160-ucode
+ !sys-firmware/iwl7260-ucode
+ !sys-firmware/iwl7265-ucode
+ !sys-firmware/iwl3160-7260-bt-ucode
+ !sys-firmware/radeon-ucode
+ )"
+#add anything else that collides to this
+
+src_unpack() {
+ if [[ ${PV} == 99999999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ # rename directory from git snapshot tarball
+ mv ${PN}-*/ ${P} || die
+ fi
+}
+
+src_prepare() {
+ echo "# Remove files that shall not be installed from this list." > ${PN}.conf
+ find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf
+
+ if use savedconfig; then
+ restore_config ${PN}.conf
+ ebegin "Removing all files not listed in config"
+ find * \( \! -type d -and \! -name ${PN}.conf \) \
+ | sort ${PN}.conf ${PN}.conf - \
+ | uniq -u | xargs -r rm
+ eend $? || die
+ # remove empty directories, bug #396073
+ find -type d -empty -delete || die
+ fi
+}
+
+src_install() {
+ if use !savedconfig; then
+ save_config ${PN}.conf
+ fi
+ rm ${PN}.conf || die
+ insinto /lib/firmware/
+ doins -r *
+}
+
+pkg_preinst() {
+ if use savedconfig; then
+ ewarn "USE=savedconfig is active. You must handle file collisions manually."
+ fi
+}
+
+pkg_postinst() {
+ elog "If you are only interested in particular firmware files, edit the saved"
+ elog "configfile and remove those that you do not want."
+}