summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-10 21:05:49 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-10 21:06:07 -0400
commit7621bfc0e2a03921b2ca981c7eb7aaef185d19e1 (patch)
treee7bb7a20fac787420d2aaf722149cd4db618e86f /sys-libs/argp-standalone
parentdev-lang/spidermonkey: fix building with clang (diff)
downloadgentoo-7621bfc0e2a03921b2ca981c7eb7aaef185d19e1.tar.gz
gentoo-7621bfc0e2a03921b2ca981c7eb7aaef185d19e1.tar.bz2
gentoo-7621bfc0e2a03921b2ca981c7eb7aaef185d19e1.zip
sys-libs/argp-standalone: build with gcc6, bug #582776
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-libs/argp-standalone')
-rw-r--r--sys-libs/argp-standalone/argp-standalone-1.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-libs/argp-standalone/argp-standalone-1.3-r1.ebuild b/sys-libs/argp-standalone/argp-standalone-1.3-r1.ebuild
new file mode 100644
index 000000000000..17c1c57b000b
--- /dev/null
+++ b/sys-libs/argp-standalone/argp-standalone-1.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Standalone argp library for use with uclibc"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/misc/"
+SRC_URI="http://www.lysator.liu.se/~nisse/misc/argp-standalone-1.3.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~ppc ~s390 ~sh ~x86"
+IUSE=""
+
+DEPEND="!sys-libs/glibc"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-throw-in-funcdef.patch"
+}
+
+src_configure() {
+ append-cflags -fgnu89-inline
+ default
+}
+
+src_install() {
+ dolib.a libargp.a
+
+ insinto /usr/include
+ doins argp.h
+}