summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-09 10:23:27 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-09 23:33:56 +0200
commit7ef3504c4fb36c875c9a58bdde62b5f8443e3bf7 (patch)
treef0bb40183e2dc97bd68b781052d7906049951c8b /sys-libs/compiler-rt/compiler-rt-9999.ebuild
parentsys-libs/compiler-rt: Simplify -- use common nolib flag var (diff)
downloadgentoo-7ef3504c4fb36c875c9a58bdde62b5f8443e3bf7.tar.gz
gentoo-7ef3504c4fb36c875c9a58bdde62b5f8443e3bf7.tar.bz2
gentoo-7ef3504c4fb36c875c9a58bdde62b5f8443e3bf7.zip
sys-libs/compiler-rt: Warn when not using clang
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-9999.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9999.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
index ffd1e9eddb3f..03c34d45531a 100644
--- a/sys-libs/compiler-rt/compiler-rt-9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
@@ -35,6 +35,13 @@ DEPEND="
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+pkg_pretend() {
+ if ! use clang && ! tc-is-clang; then
+ ewarn "Building using a compiler other than clang may result in broken atomics"
+ ewarn "library. Enable USE=clang unless you have a very good reason not to."
+ fi
+}
+
pkg_setup() {
llvm_pkg_setup
python-any-r1_pkg_setup