summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-05 21:30:11 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-05 21:32:18 +0100
commit094ebf93f64402309ca17c1313c60a9661162df5 (patch)
tree4a24bb54a688d4249ca4b4a763f0cb7c95a348a2 /sys-libs/compiler-rt
parentdev-libs/criterion: improve ebuild (diff)
downloadgentoo-094ebf93f64402309ca17c1313c60a9661162df5.tar.gz
gentoo-094ebf93f64402309ca17c1313c60a9661162df5.tar.bz2
gentoo-094ebf93f64402309ca17c1313c60a9661162df5.zip
sys-libs/compiler-rt: Add missing python_check_deps()
Closes: https://bugs.gentoo.org/702494 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/compiler-rt')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild4
-rw-r--r--sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild6
-rw-r--r--sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild6
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild4
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild4
5 files changed, 22 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
index 2adcb2a2721c..c709777f6bbd 100644
--- a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
@@ -32,6 +32,10 @@ BDEPEND="
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+python_check_deps() {
+ has_version "dev-python/lit[${PYTHON_USEDEP}]"
+}
+
pkg_pretend() {
if ! use clang && ! tc-is-clang; then
ewarn "Building using a compiler other than clang may result in broken atomics"
diff --git a/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild b/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
index 1c2404f43c0f..dc6beaa1fa95 100644
--- a/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -36,6 +36,10 @@ S=${WORKDIR}/${P/_/}.src
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+python_check_deps() {
+ has_version "dev-python/lit[${PYTHON_USEDEP}]"
+}
+
pkg_pretend() {
if ! use clang && ! tc-is-clang; then
ewarn "Building using a compiler other than clang may result in broken atomics"
diff --git a/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
index ca77d0bb9d83..aa5a64dc369d 100644
--- a/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -37,6 +37,10 @@ S=${WORKDIR}/${MY_P}
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+python_check_deps() {
+ has_version "dev-python/lit[${PYTHON_USEDEP}]"
+}
+
pkg_pretend() {
if ! use clang && ! tc-is-clang; then
ewarn "Building using a compiler other than clang may result in broken atomics"
diff --git a/sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild b/sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild
index d7de81b109c2..5625439d2c6a 100644
--- a/sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild
@@ -38,6 +38,10 @@ PATCHES=(
"${FILESDIR}"/9.0.0/0001-compiler-rt-crt-make-test-case-nontrivial-in-check_c.patch
)
+python_check_deps() {
+ has_version "dev-python/lit[${PYTHON_USEDEP}]"
+}
+
pkg_pretend() {
if ! use clang && ! tc-is-clang; then
ewarn "Building using a compiler other than clang may result in broken atomics"
diff --git a/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
index a06fc79c1f65..d6d21f789d1b 100644
--- a/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
@@ -32,6 +32,10 @@ BDEPEND="
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
+python_check_deps() {
+ has_version "dev-python/lit[${PYTHON_USEDEP}]"
+}
+
pkg_pretend() {
if ! use clang && ! tc-is-clang; then
ewarn "Building using a compiler other than clang may result in broken atomics"