summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2016-12-07 02:01:57 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-07 02:02:27 -0500
commit43e0e8838d4f259a2c9252da59649de4677f36f1 (patch)
tree10de5bdf879e1c800b60ddc6e8d686abda369cfb /sys-libs/glibc/files
parentdev-util/android-studio: drop old (diff)
downloadgentoo-43e0e8838d4f259a2c9252da59649de4677f36f1.tar.gz
gentoo-43e0e8838d4f259a2c9252da59649de4677f36f1.tar.bz2
gentoo-43e0e8838d4f259a2c9252da59649de4677f36f1.zip
sys-libs/glibc: hack initial mips cross headers for 2.21+
The mips preconfigure script has changed (again), so update the hacks for the early cross-compile glibc headers phase. URL: https://crbug.com/647033
Diffstat (limited to 'sys-libs/glibc/files')
-rw-r--r--sys-libs/glibc/files/eblits/src_configure.eblit8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-libs/glibc/files/eblits/src_configure.eblit b/sys-libs/glibc/files/eblits/src_configure.eblit
index 396bce52ca29..c1e6a2d1719d 100644
--- a/sys-libs/glibc/files/eblits/src_configure.eblit
+++ b/sys-libs/glibc/files/eblits/src_configure.eblit
@@ -226,6 +226,14 @@ toolchain-glibc_headers_configure() {
pushd "${S}"/sysdeps/mips >/dev/null
sed -i -e '/^CC +=/s:=.*:= -D_MIPS_SZPTR=32:' mips32/Makefile mips64/n32/Makefile || die
sed -i -e '/^CC +=/s:=.*:= -D_MIPS_SZPTR=64:' mips64/n64/Makefile || die
+ if version_is_at_least 2.21 ; then
+ # Force the mips ABI to the default. This is OK because the set of
+ # installed headers in this phase is the same between the 3 ABIs.
+ # If this ever changes, this hack will break, but that's unlikely
+ # as glibc discourages that behavior.
+ # https://crbug.com/647033
+ sed -i -e 's:abiflag=.*:abiflag=_ABIO32:' preconfigure || die
+ fi
popd >/dev/null
fi