summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-10-24 22:41:26 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-10-24 22:41:39 +0100
commitcbda286a2f7c63bf8075cb999e64c26835530c68 (patch)
tree5a83e08c539966ca30514d90bd42719734987999 /sys-libs/glibc/glibc-2.19-r2.ebuild
parenttoolchain-glibc.eclass: drop PIE ewarn (diff)
downloadgentoo-cbda286a2f7c63bf8075cb999e64c26835530c68.tar.gz
gentoo-cbda286a2f7c63bf8075cb999e64c26835530c68.tar.bz2
gentoo-cbda286a2f7c63bf8075cb999e64c26835530c68.zip
sys-libs/glibc: drop PIE ewarn
The ewarn lacks '<gcc-6' guard. Let's drop ewarn completely. Reported-by: Alexander Tsoy Closes: https://bugs.gentoo.org/669410 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-libs/glibc/glibc-2.19-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.19-r2.ebuild5
1 files changed, 1 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.19-r2.ebuild b/sys-libs/glibc/glibc-2.19-r2.ebuild
index 3ff1fb95b99b..496ac4d5a31a 100644
--- a/sys-libs/glibc/glibc-2.19-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.19-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -628,9 +628,6 @@ sanity_prechecks() {
ewarn "hypervisor, which is probably not what you want."
fi
- use hardened && ! tc-enables-pie && \
- ewarn "PIE hardening not applied, as your compiler doesn't default to PIE"
-
# Check for sanity of /etc/nsswitch.conf
if [[ -e ${EROOT}/etc/nsswitch.conf ]] ; then
local entry