summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-07 18:43:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-07 19:39:44 +0000
commit91a02442c5a6c157bf9de58b20d327c88e9fac20 (patch)
tree7cd0bbc4235166e69027966e8c653197d0cfd0a4 /sys-libs/glibc/glibc-2.24-r4.ebuild
parentsys-libs/musl: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only (diff)
downloadgentoo-91a02442c5a6c157bf9de58b20d327c88e9fac20.tar.gz
gentoo-91a02442c5a6c157bf9de58b20d327c88e9fac20.tar.bz2
gentoo-91a02442c5a6c157bf9de58b20d327c88e9fac20.zip
sys-libs/glibc: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only
CROSSCOMPILE_OPTS is a USE_EXPAND of a single item: headers-only. Convert it to a global USE flag instead. Mechanical ebuild rename done as: $ sed -e 's@crosscompile_opts_headers-only@headers-only@g' \ -i $(git grep -l headers-only) 'headers-only' flag is used by crossdev to bootstrap stage1 compiler before libc is available. crossdev switched to USE=headers-only in =sys-devel/crossdev-20171230. Bug: https://bugs.gentoo.org/642712 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-libs/glibc/glibc-2.24-r4.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.24-r4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.24-r4.ebuild b/sys-libs/glibc/glibc-2.24-r4.ebuild
index 29a17f827aec..eb338ca1447b 100644
--- a/sys-libs/glibc/glibc-2.24-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.24-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -30,7 +30,7 @@ GCC_BOOTSTRAP_VER="4.7.3-r1"
PATCH_VER="10" # Gentoo patchset
: ${NPTL_KERN_VER:="2.6.32"} # min kernel version nptl requires
-IUSE="audit caps debug gd hardened multilib nscd +rpc selinux systemtap profile suid vanilla crosscompile_opts_headers-only"
+IUSE="audit caps debug gd hardened multilib nscd +rpc selinux systemtap profile suid vanilla headers-only"
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -82,7 +82,7 @@ RDEPEND="${COMMON_DEPEND}
!sys-libs/nss-db"
if [[ ${CATEGORY} == cross-* ]] ; then
- DEPEND+=" !crosscompile_opts_headers-only? (
+ DEPEND+=" !headers-only? (
>=${CATEGORY}/binutils-2.24
>=${CATEGORY}/gcc-4.7
)"