summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-04-03 23:37:33 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-03 23:37:33 +0100
commit93ceed55cd26146919435836599a90e17a5dddba (patch)
tree74ad02d93721fdaf1058826cb298a9ba3b033568 /sys-libs/glibc/glibc-2.29-r8.ebuild
parentdev-python/flake8: revert back to ~ia64 (diff)
downloadgentoo-93ceed55cd26146919435836599a90e17a5dddba.tar.gz
gentoo-93ceed55cd26146919435836599a90e17a5dddba.tar.bz2
gentoo-93ceed55cd26146919435836599a90e17a5dddba.zip
sys-libs/glibc: switch -fstack-protector-all to -strong, bug #712356
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-2.29-r8.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.29-r8.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.29-r8.ebuild b/sys-libs/glibc/glibc-2.29-r8.ebuild
index c869cce61d55..c95d7016c40f 100644
--- a/sys-libs/glibc/glibc-2.29-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.29-r8.ebuild
@@ -812,7 +812,11 @@ glibc_do_configure() {
myconf+=( --enable-stack-protector=no )
;;
*)
- myconf+=( --enable-stack-protector=$(usex ssp all no) )
+ # Use '=strong' instead of '=all' to protect only functions
+ # worth protecting from stack smashes.
+ # '=all' is also known to have a problem in IFUNC resolution
+ # tests: https://sourceware.org/PR25680, bug #712356.
+ myconf+=( --enable-stack-protector=$(usex ssp strong no) )
;;
esac
myconf+=( --enable-stackguard-randomization )