summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-21 23:24:59 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-21 23:25:19 +0200
commit3c4ea812e61978466afdbf77e44e04f808762e07 (patch)
tree401ca84ba7c7e44debc3aef9c2ada0c07832ab04 /sys-libs/glibc/glibc-9999.ebuild
parentmedia-libs/gegl: 0.3.34 (diff)
downloadgentoo-3c4ea812e61978466afdbf77e44e04f808762e07.tar.gz
gentoo-3c4ea812e61978466afdbf77e44e04f808762e07.tar.bz2
gentoo-3c4ea812e61978466afdbf77e44e04f808762e07.zip
sys-libs/glibc: Remove useflag debug and related logic. Bug 601718.
Closes: https://bugs.gentoo.org/601718 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild10
1 files changed, 1 insertions, 9 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 2e5552b3dcc8..ca23762e8d4a 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -33,7 +33,7 @@ PATCH_VER=5
SRC_URI+=" https://dev.gentoo.org/~dilfridge/distfiles/${P}-patches-${PATCH_VER}.tar.bz2"
SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2 )"
-IUSE="audit caps compile-locales debug doc gd hardened headers-only multilib nscd profile selinux suid systemtap vanilla"
+IUSE="audit caps compile-locales doc gd hardened headers-only multilib nscd profile selinux suid systemtap vanilla"
# Minimum kernel version that glibc requires
MIN_KERN_VER="3.2.0"
@@ -775,14 +775,6 @@ src_prepare() {
einfo "Installing Hardened Gentoo SSP and FORTIFY_SOURCE handler"
cp "${FILESDIR}"/2.20/glibc-2.20-gentoo-stack_chk_fail.c debug/stack_chk_fail.c || die
cp "${FILESDIR}"/2.25/glibc-2.25-gentoo-chk_fail.c debug/chk_fail.c || die
-
- if use debug ; then
- # Allow SIGABRT to dump core on non-hardened systems, or when debug is requested.
- sed -i \
- -e '/^CFLAGS-backtrace.c/ iCPPFLAGS-stack_chk_fail.c = -DSSP_SMASH_DUMPS_CORE' \
- -e '/^CFLAGS-backtrace.c/ iCPPFLAGS-chk_fail.c = -DSSP_SMASH_DUMPS_CORE' \
- debug/Makefile || die
- fi
fi
}