summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-05-01 22:18:52 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-05-01 22:19:17 +0200
commit589ce025faee90c57c76c0da6f8534f707132d8f (patch)
tree001b3290884ceb55a78dd16d7f6614743566abba /sys-libs/glibc/glibc-9999.ebuild
parentdev-libs/libxslt: s390 stable wrt bug #637310 (diff)
downloadgentoo-589ce025faee90c57c76c0da6f8534f707132d8f.tar.gz
gentoo-589ce025faee90c57c76c0da6f8534f707132d8f.tar.bz2
gentoo-589ce025faee90c57c76c0da6f8534f707132d8f.zip
sys-libs/glibc: Add new bootstrap files from stages, bug 647070
See https://github.com/gentoo/gcc-multilib-bootstrap/ for the source. This is as good as we can do at the moment. Tested by building an x32 glibc on a normal amd64 system. For the glibc-2.26 stabilization we still need new files for PowerPC. Current status: * amd64, x32, x86: Files from gcc-6.4 * s390, s390x: Files from gcc-5.4 (does this work?) * ppc, ppc64: no files, since only gcc-4.9 available * n32, n64, o32: no files, last mips stages are years old, not useful Bug: https://bugs.gentoo.org/647070 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index ca23762e8d4a..7c5d09ab85ac 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -25,13 +25,13 @@ fi
RELEASE_VER=${PV}
-GCC_BOOTSTRAP_VER="4.7.3-r1"
+GCC_BOOTSTRAP_VER=20180501
# Gentoo patchset
PATCH_VER=5
SRC_URI+=" https://dev.gentoo.org/~dilfridge/distfiles/${P}-patches-${PATCH_VER}.tar.bz2"
-SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2 )"
+SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-multilib-bootstrap-${GCC_BOOTSTRAP_VER}.tar.xz )"
IUSE="audit caps compile-locales doc gd hardened headers-only multilib nscd profile selinux suid systemtap vanilla"
@@ -730,7 +730,7 @@ src_unpack() {
# Consistency is not guaranteed between pkg_ and src_ ...
sanity_prechecks
- use multilib && unpack gcc-${GCC_BOOTSTRAP_VER}-multilib-bootstrap.tar.bz2
+ use multilib && unpack gcc-multilib-bootstrap-${GCC_BOOTSTRAP_VER}.tar.xz
setup_env
@@ -933,7 +933,7 @@ glibc_do_configure() {
if [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib ; then
echo 'main(){}' > "${T}"/test.c
if ! $(tc-getCC ${CTARGET}) ${CFLAGS} ${LDFLAGS} "${T}"/test.c -Wl,-emain -lgcc 2>/dev/null ; then
- sed -i -e '/^CC = /s:$: -B$(objdir)/../'"gcc-${GCC_BOOTSTRAP_VER}/${ABI}:" config.make || die
+ sed -i -e '/^CC = /s:$: -B$(objdir)/../'"gcc-multilib-bootstrap-${GCC_BOOTSTRAP_VER}/${ABI}:" config.make || die
fi
fi
}