summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-06-13 21:45:58 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-06-13 21:46:38 +0100
commit6c3740323094626403ee2e57f4a0c5b1cb4f37bb (patch)
tree971b72f44f46b7264094acfe3323c620415fcc3e /sys-libs/glibc/glibc-9999.ebuild
parentnet-libs/librsync: 2.0.2 version bump (diff)
downloadgentoo-6c3740323094626403ee2e57f4a0c5b1cb4f37bb.tar.gz
gentoo-6c3740323094626403ee2e57f4a0c5b1cb4f37bb.tar.bz2
gentoo-6c3740323094626403ee2e57f4a0c5b1cb4f37bb.zip
sys-libs/glibc: fix -mfpu=neon build failure, bug #657760
CFLAGS=-mfpu=neon tricked glibc into not building memcpy() implementation. It's caused by the fact that -mfpu=neon was passed when building .c files, but was not passed when building .S files. This change passes CFLAGS to CPPFLAGS to apply to .S files. Reported-by: Markus Meier Closes: https://bugs.gentoo.org/657760 Bug: https://sourceware.org/PR23273 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index d628938b2a70..7a1ae16ce825 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -798,6 +798,12 @@ glibc_do_configure() {
export CXX="$(tc-getCXX ${CTARGET}) $(get_abi_CFLAGS)"
einfo " $(printf '%15s' 'Manual CXX:') ${CXX}"
+ # CFLAGS can contain ABI-spefcific flags like -mfpu=neon, see bug #657760
+ # To build .S (assembly) files with the same ABI-specific flags
+ # upstream currently recommends adding CFLAGS to CPPFLAGS: https://sourceware.org/PR23273
+ export CPPFLAGS="${CPPFLAGS} ${CFLAGS}"
+ einfo " $(printf '%15s' 'Manual CPPFLAGS:') ${CPPFLAGS}"
+
echo
local myconf=()