summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-12-25 17:28:55 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-12-25 18:57:58 +0800
commit7c1ace82e82ecebd13ac180bb0d1e6d82258e99b (patch)
tree0cf192ec55cd3c93ac6b0d5c7d5d23c2f436b3eb /sys-libs/glibc/glibc-9999.ebuild
parentmedia-gfx/graphviz: stable 2.42.3 for sparc, bug #703582 (diff)
downloadgentoo-7c1ace82e82ecebd13ac180bb0d1e6d82258e99b.tar.gz
gentoo-7c1ace82e82ecebd13ac180bb0d1e6d82258e99b.tar.bz2
gentoo-7c1ace82e82ecebd13ac180bb0d1e6d82258e99b.zip
sys-libs/glibc: cross-*: pass EPREFIX to --with-headers
This is a follow up of ea4cbdc9159c0ebbd29d4062bbb314393a8cc32f. Otherwise when building cross toolchain on Gentoo Prefix, configure cannot find the needed linux-headers. Bug: https://bugs.gentoo.org/642604 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index a3d9d33a3686..94ff23bb27e8 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -929,7 +929,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
$(use_with gd)
- --with-headers=$(alt_build_headers)
+ --with-headers=$(build_eprefix)$(alt_build_headers)
--prefix="$(host_eprefix)/usr"
--sysconfdir="$(host_eprefix)/etc"
--localstatedir="$(host_eprefix)/var"
@@ -1084,7 +1084,7 @@ glibc_headers_configure() {
--enable-bind-now
--build=${CBUILD_OPT:-${CBUILD}}
--host=${CTARGET_OPT:-${CTARGET}}
- --with-headers=$(alt_build_headers)
+ --with-headers=$(build_eprefix)$(alt_build_headers)
--prefix="$(host_eprefix)/usr"
${EXTRA_ECONF}
)