summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2020-03-22 11:02:40 +0100
committerAndreas K. Huettel <dilfridge@gentoo.org>2020-03-22 11:39:20 +0100
commit8ded2e75400a506858540110fb837b1777f01d2c (patch)
treea2c8f000516e3fe78fe0b355a95d756c00a45153 /sys-libs/glibc/glibc-9999.ebuild
parentsci-electronics/iverilog: x86 stable wrt bug #713730 (diff)
downloadgentoo-8ded2e75400a506858540110fb837b1777f01d2c.tar.gz
gentoo-8ded2e75400a506858540110fb837b1777f01d2c.tar.bz2
gentoo-8ded2e75400a506858540110fb837b1777f01d2c.zip
sys-libs/glibc: add XFAIL mechanism to 9999
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild33
1 files changed, 32 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 7af2bc9cf75b..fc5b12bfb5e9 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -129,6 +129,26 @@ else
PDEPEND+=" !vanilla? ( sys-libs/timezone-data )"
fi
+# Ignore tests whitelisted below
+GENTOO_GLIBC_XFAIL_TESTS="${GENTOO_GLIBC_XFAIL_TESTS:-yes}"
+
+# The following tests fail due to the Gentoo build system and are thus
+# executed but ignored:
+XFAIL_TEST_LIST=(
+ # 1) Sandbox
+ tst-ldconfig-bad-aux-cache
+ tst-pldd
+ tst-mallocfork2
+ tst-nss-db-endgrent
+ tst-nss-db-endpwent
+ tst-nss-files-hosts-long
+ tst-nss-test3
+ # 2) Namespaces and cgroup
+ tst-locale-locpath
+ # 9) Failures of unknown origin
+ tst-latepthread
+)
+
#
# Small helper functions
#
@@ -1139,11 +1159,22 @@ src_compile() {
glibc_src_test() {
cd "$(builddir nptl)"
+
+ local myxfailparams=""
+ if [[ "${GENTOO_GLIBC_XFAIL_TESTS}" == "yes" ]] ; then
+ for myt in ${XFAIL_TEST_LIST[@]} ; do
+ myxfailparams+="test-xfail-${myt}=yes "
+ done
+ fi
+
# disable tests:
# - tests-container:
# sandbox does not understand unshare() and prevents
# writes to /proc/
- emake check tests-container=
+ # emake ${myxfailparams} check tests-container=
+ # if possible let's list them (unless it's *all* container tests)
+
+ emake ${myxfailparams} check
}
do_src_test() {