summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-15 13:50:35 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-15 13:50:47 +0000
commit959cf0a3b9fbb0de4181bb128a9c484d9f0153f1 (patch)
tree338b40c6c5bd42b0e4b507683eb93e0f1d5129f4 /sys-libs/glibc/glibc-9999.ebuild
parentsci-physics/lammps: add kokkos support (diff)
downloadgentoo-959cf0a3b9fbb0de4181bb128a9c484d9f0153f1.tar.gz
gentoo-959cf0a3b9fbb0de4181bb128a9c484d9f0153f1.tar.bz2
gentoo-959cf0a3b9fbb0de4181bb128a9c484d9f0153f1.zip
sys-libs/glibc: disable container tests, bug #712356
sandbox is not very compatible with filesystem unshare(). It can't check if mkdir(/proc) is a safe operation under unshare/chroot. Let's disable container tests. One day we can enable them if not running under sandbox. Shoul deal with the following test failures: FAIL: elf/tst-dlopen-self-container FAIL: elf/tst-dlopen-tlsmodid-container FAIL: elf/tst-ifunc-fault-bindnow FAIL: elf/tst-ifunc-fault-lazy FAIL: elf/tst-ldconfig-bad-aux-cache FAIL: elf/tst-ldconfig-ld_so_conf-update FAIL: elf/tst-pldd Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/712356 Package-Manager: Portage-2.3.94, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index a457c751d18d..229af08f2ca8 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1136,7 +1136,11 @@ src_compile() {
glibc_src_test() {
cd "$(builddir nptl)"
- emake check
+ # disable tests:
+ # - tests-container:
+ # sandbox does not understand unshare() and prevents
+ # writes to /proc/
+ emake check tests-container=
}
do_src_test() {