summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-16 12:27:17 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-16 12:30:49 +0100
commitc6c63ec156e40e8b28724f2b49a8b0cf2ebf3033 (patch)
treed1fd40294a37356eb9f9ffba0977cded8a6b4efc /sys-libs/glibc/glibc-9999.ebuild
parentdev-python/ws4py: arm stable wrt bug #722240 (diff)
downloadgentoo-c6c63ec156e40e8b28724f2b49a8b0cf2ebf3033.tar.gz
gentoo-c6c63ec156e40e8b28724f2b49a8b0cf2ebf3033.tar.bz2
gentoo-c6c63ec156e40e8b28724f2b49a8b0cf2ebf3033.zip
sys-libs/glibc: revert "use -mno-sdata, not -fcommon, bug #723268"
The underying linker failure cause is not just an overflow but a functional difference in '_dl_sysinfo_break' symbol linkage. '_dl_sysinfo_break' is defined as a function in assembly but declared as a global 'common' variable. Making it non-common actually breaks sysinfo handler which is expected to be called without function descriptor indirection. As sysonfo handler is called before rtld processed it's own relocations. Let's revert back to -fcommon until we have better glibc fix. This reverts commit 8ec720b67f38952a4b9c6054c6d8ef0fc79d0343. Bug: https://bugs.gentoo.org/723268 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index ccedec70c678..2355e5bce34e 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -302,8 +302,7 @@ setup_target_flags() {
# Workaround GPREL22 overflow by slightly pessimizing global
# references to go via 64-bit relocations instead of 22-bit ones.
# This allows building glibc on ia64 without an overflow: #723268
- append-flags -mno-sdata
- :
+ append-flags -fcommon
;;
mips)
# The mips abi cannot support the GNU style hashes. #233233