summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-20 19:12:20 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-20 19:13:09 +0100
commitc865354644b43a2f36c3feb5aba5ca60a4e179f9 (patch)
treefc2e2492cb8a77623cb27eae3de2c5cec391daff /sys-libs/glibc/glibc-9999.ebuild
parentsys-libs/glibc: Restructure sanity tests (diff)
downloadgentoo-c865354644b43a2f36c3feb5aba5ca60a4e179f9.tar.gz
gentoo-c865354644b43a2f36c3feb5aba5ca60a4e179f9.tar.bz2
gentoo-c865354644b43a2f36c3feb5aba5ca60a4e179f9.zip
sys-libs/glibc: Do not check for IA32 abi when merging binary package
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 224a4f232d08..87549b89f6db 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -640,7 +640,7 @@ sanity_prechecks() {
# we test for...
if ! is_crosscompile ; then
- if use amd64 && use multilib ; then
+ if use amd64 && use multilib && [[ ${MERGE_TYPE} != "binary" ]] ; then
ebegin "Checking that IA32 emulation is enabled in the running kernel"
echo 'int main(){return 0;}' > "${T}/check-ia32-emulation.c"
"${CC-${CHOST}-gcc}" ${CFLAGS_x86} "${T}/check-ia32-emulation.c" -o "${T}/check-ia32-emulation.elf32"