summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-05-12 08:02:54 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-05-12 08:05:21 +0300
commitcc79a30709cc296470454c1a13a40a3ed5639c37 (patch)
treeea9bee006a18f2ad1643d5ea42b3c2bb340fb042 /sys-libs/glibc/glibc-9999.ebuild
parentapp-misc/solaar: prune old versions (diff)
downloadgentoo-cc79a30709cc296470454c1a13a40a3ed5639c37.tar.gz
gentoo-cc79a30709cc296470454c1a13a40a3ed5639c37.tar.bz2
gentoo-cc79a30709cc296470454c1a13a40a3ed5639c37.zip
sys-libs/glibc: Use externally packaged locale-gen
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index aec5e3c69a72..32cac60af6ee 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -28,10 +28,14 @@ RELEASE_VER=${PV}
GCC_BOOTSTRAP_VER=20180511
+LOCALE_GEN_VER=2.00
+
# Gentoo patchset
PATCH_VER=16
+PATCH_DEV=slyfox
-SRC_URI+=" https://dev.gentoo.org/~slyfox/distfiles/${P}-patches-${PATCH_VER}.tar.xz"
+SRC_URI+=" https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${P}-patches-${PATCH_VER}.tar.xz"
+SRC_URI+=" https://gitweb.gentoo.org/proj/locale-gen.git/snapshot/locale-gen-${LOCALE_GEN_VER}.tar.gz"
SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-multilib-bootstrap-${GCC_BOOTSTRAP_VER}.tar.xz )"
IUSE="audit caps cet compile-locales +crypt custom-cflags doc gd headers-only +multiarch multilib nscd profile selinux +ssp +static-libs static-pie suid systemtap test vanilla"
@@ -728,6 +732,8 @@ src_unpack() {
cd "${WORKDIR}" || die
unpack glibc-${RELEASE_VER}-patches-${PATCH_VER}.tar.xz
+
+ unpack locale-gen-${LOCALE_GEN_VER}.tar.gz
}
src_prepare() {
@@ -744,6 +750,12 @@ src_prepare() {
cd "${WORKDIR}"
find . -name configure -exec touch {} +
+ # until the patchset is updated
+ rm -rf extra/locale || die
+
+ # move the external locale-gen to its old place
+ mv locale-gen-${LOCALE_GEN_VER} extra/locale || die
+
eprefixify extra/locale/locale-gen
# Fix permissions on some of the scripts.