summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-20 20:14:07 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-20 20:14:23 +0100
commite1643a784e0c0626933e93d60e6dc229deb0757e (patch)
tree12907dc89bead002ef09a56597dca3832d7a35ea /sys-libs/glibc/glibc-9999.ebuild
parentapp-i18n/poedit: bump to 2.0.6, fixes hanging with certain rare non-UTF8 PO f... (diff)
downloadgentoo-e1643a784e0c0626933e93d60e6dc229deb0757e.tar.gz
gentoo-e1643a784e0c0626933e93d60e6dc229deb0757e.tar.bz2
gentoo-e1643a784e0c0626933e93d60e6dc229deb0757e.zip
sys-libs/glibc: Re-add check for bug 279260, see bug 645016 comment 2
Bug: https://bugs.gentoo.org/279260 Bug: https://bugs.gentoo.org/645016 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 87549b89f6db..a739da784a7e 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -612,6 +612,12 @@ sanity_prechecks() {
die "Please fix your CHOST"
fi
+ if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then
+ eerror "Your old kernel is broken. You need to update it to a newer"
+ eerror "version as syscall(<bignum>) will break. See bug 279260."
+ die "Old and broken kernel."
+ fi
+
if [[ -e /proc/xen ]] && [[ $(tc-arch) == "x86" ]] && ! is-flag -mno-tls-direct-seg-refs ; then
ewarn "You are using Xen but don't have -mno-tls-direct-seg-refs in your CFLAGS."
ewarn "This will result in a 50% performance penalty when running with a 32bit"