summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-11 21:02:52 +0000
committerSam James <sam@gentoo.org>2021-11-11 21:02:52 +0000
commit3d081cb997d18d200c71e1ff394e17db2f01f38d (patch)
tree3b43c0aee4bfd88179d0df63f8a3deb54baa0bbf /sys-libs/glibc
parentwww-apps/nextcloud: 22.2.1, 21.0.6, 20.0.14 bumps (diff)
downloadgentoo-3d081cb997d18d200c71e1ff394e17db2f01f38d.tar.gz
gentoo-3d081cb997d18d200c71e1ff394e17db2f01f38d.tar.bz2
gentoo-3d081cb997d18d200c71e1ff394e17db2f01f38d.zip
sys-libs/glibc: drop Python 3.10 from PYTHON_COMPAT to avoid circular deps
Needed for now to try help upgrades and avoid circular dependencies with glibc -> python -> libcrypt -> libxcrypt -> glibc -> ... Bug: https://bugs.gentoo.org/699422 Bug: https://bugs.gentoo.org/702806 Bug: https://bugs.gentoo.org/809410 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.33-r7.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.34-r1.ebuild5
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.33-r7.ebuild b/sys-libs/glibc/glibc-2.33-r7.ebuild
index cb9826d7be2b..20390ea8ba2a 100644
--- a/sys-libs/glibc/glibc-2.33-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.33-r7.ebuild
@@ -3,7 +3,10 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+# We avoid Python 3.10 here _for now_ (it does work!) to avoid circular dependencies
+# on upgrades as people migrate to libxcrypt.
+# https://wiki.gentoo.org/wiki/User:Sam/Portage_help/Circular_dependencies#Python_and_libcrypt
+PYTHON_COMPAT=( python3_{7,8,9} )
TMPFILES_OPTIONAL=1
inherit python-any-r1 prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \
diff --git a/sys-libs/glibc/glibc-2.34-r1.ebuild b/sys-libs/glibc/glibc-2.34-r1.ebuild
index 461ad27a5e24..f5d98be9cf6a 100644
--- a/sys-libs/glibc/glibc-2.34-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r1.ebuild
@@ -6,7 +6,10 @@ EAPI=7
# Bumping notes: https://wiki.gentoo.org/wiki/Project:Toolchain/sys-libs/glibc
# Please read & adapt the page as necessary if obsolete.
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+# We avoid Python 3.10 here _for now_ (it does work!) to avoid circular dependencies
+# on upgrades as people migrate to libxcrypt.
+# https://wiki.gentoo.org/wiki/User:Sam/Portage_help/Circular_dependencies#Python_and_libcrypt
+PYTHON_COMPAT=( python3_{7,8,9} )
TMPFILES_OPTIONAL=1
inherit python-any-r1 prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index b08e07445f50..ce5ad8d3c43d 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -6,7 +6,10 @@ EAPI=7
# Bumping notes: https://wiki.gentoo.org/wiki/Project:Toolchain/sys-libs/glibc
# Please read & adapt the page as necessary if obsolete.
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+# We avoid Python 3.10 here _for now_ (it does work!) to avoid circular dependencies
+# on upgrades as people migrate to libxcrypt.
+# https://wiki.gentoo.org/wiki/User:Sam/Portage_help/Circular_dependencies#Python_and_libcrypt
+PYTHON_COMPAT=( python3_{7,8,9} )
TMPFILES_OPTIONAL=1
inherit python-any-r1 prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \