summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-18 07:46:54 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-18 07:47:16 +0100
commit629fb0560bffdf39a923c6ee794eddfb815db579 (patch)
treec8724fd8ffcfe61eb5068ba6a6652ad89f781279 /sys-libs/glibc
parentdev-python/aiodns: use correct typing distribution (diff)
downloadgentoo-629fb0560bffdf39a923c6ee794eddfb815db579.tar.gz
gentoo-629fb0560bffdf39a923c6ee794eddfb815db579.tar.bz2
gentoo-629fb0560bffdf39a923c6ee794eddfb815db579.zip
sys-libs/glibc: avoid RESTRICT=strip and use 'dostrip -x /'
RESTRICT=strip + 'dostrip /' does not have a desired effect of enabling (possibly selective) stripping in portage: https://bugs.gentoo.org/697960 Workaround it by using 'if foo && dostrip -x /' instead of RESTRICT=strip + 'if foo || dostrip /'. Reported-by: Arfrever Frehtes Taifersar Arahesis Fixed-by: Arfrever Frehtes Taifersar Arahesis Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index d1ad8e513fbb..08a4eba83b3e 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -80,7 +80,6 @@ fi
# losing it's '.symtab' entries.
# As Gentoo's strip does not allow us to pass less aggressive stripping
# options and does not check the machine target we strip selectively.
-RESTRICT=strip
# We need a new-enough binutils/gcc to match upstream baseline.
# Also we need to make sure our binutils/gcc supports TLS,
@@ -1204,7 +1203,7 @@ glibc_do_src_install() {
# Avoid stripping binaries not targeted by ${CHOST}. Or else
# ${CHOST}-strip would break binaries build for ${CTARGET}.
- is_crosscompile || dostrip /
+ is_crosscompile && dostrip -x /
# gdb thread introspection relies on local libpthreas symbols. stripping breaks it
# See Note [Disable automatic stripping]
dostrip -x $(alt_libdir)/libpthread-${upstream_pv}.so