summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-14 07:57:44 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-14 07:58:05 +0100
commit650d70eb5d91265329e2f730bc1aed0fa5863db6 (patch)
treeec97371435e35cf96f2090296974632588fa3020 /sys-libs/glibc
parentsys-kernel/git-sources: Automated version bump to 5.4_rc3. (diff)
downloadgentoo-650d70eb5d91265329e2f730bc1aed0fa5863db6.tar.gz
gentoo-650d70eb5d91265329e2f730bc1aed0fa5863db6.tar.bz2
gentoo-650d70eb5d91265329e2f730bc1aed0fa5863db6.zip
sys-libs/glibc: disable stripping for cross-glibc
commit e14229b10b513a164f8379ff14cc8c644c071f27 dropped special stripping and relied on standard ${CHOST}-strip. Unfortunately one special case wa missing: cross-*/glibc ebuilds use ${CTARGET} as a target and are installed into the host. That causes ${CHOST}-strip to be called on ${CTARGET} binaries. If multitarget is not enabled strip either breaks such bianries or makes them untouched. Disable tripping until we migrated off off cross-*/glibc ebuilds. Reported-by: Johannes Geiss Closes: https://bugs.gentoo.org/697428 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.19-r2.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.24-r4.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.25-r11.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.26-r7.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.27-r6.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.28-r6.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.29-r2.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.29-r4.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.29-r5.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.30-r1.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.30.ebuild3
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild3
12 files changed, 36 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.19-r2.ebuild b/sys-libs/glibc/glibc-2.19-r2.ebuild
index 0fedbb8e9409..20b236f90376 100644
--- a/sys-libs/glibc/glibc-2.19-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.19-r2.ebuild
@@ -56,6 +56,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.24-r4.ebuild b/sys-libs/glibc/glibc-2.24-r4.ebuild
index b808611bd319..4c8624988553 100644
--- a/sys-libs/glibc/glibc-2.24-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.24-r4.ebuild
@@ -49,6 +49,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.25-r11.ebuild b/sys-libs/glibc/glibc-2.25-r11.ebuild
index e2a0f9131bbc..4b3ac83a890b 100644
--- a/sys-libs/glibc/glibc-2.25-r11.ebuild
+++ b/sys-libs/glibc/glibc-2.25-r11.ebuild
@@ -51,6 +51,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.26-r7.ebuild b/sys-libs/glibc/glibc-2.26-r7.ebuild
index 34d8fb8a7ac9..80530db6e453 100644
--- a/sys-libs/glibc/glibc-2.26-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.26-r7.ebuild
@@ -55,6 +55,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.27-r6.ebuild b/sys-libs/glibc/glibc-2.27-r6.ebuild
index f1409e36cf34..2b333181bf71 100644
--- a/sys-libs/glibc/glibc-2.27-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.27-r6.ebuild
@@ -55,6 +55,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.28-r6.ebuild b/sys-libs/glibc/glibc-2.28-r6.ebuild
index aa318b7e0f1b..2a512a62aece 100644
--- a/sys-libs/glibc/glibc-2.28-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.28-r6.ebuild
@@ -55,6 +55,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.29-r2.ebuild b/sys-libs/glibc/glibc-2.29-r2.ebuild
index b80ddd008144..bd08c9a208a8 100644
--- a/sys-libs/glibc/glibc-2.29-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.29-r2.ebuild
@@ -57,6 +57,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.29-r4.ebuild b/sys-libs/glibc/glibc-2.29-r4.ebuild
index 7282d89d8eee..0f388a106c6e 100644
--- a/sys-libs/glibc/glibc-2.29-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.29-r4.ebuild
@@ -57,6 +57,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.29-r5.ebuild b/sys-libs/glibc/glibc-2.29-r5.ebuild
index 1c3f4a15dde7..6ac0497d07cd 100644
--- a/sys-libs/glibc/glibc-2.29-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.29-r5.ebuild
@@ -57,6 +57,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.30-r1.ebuild b/sys-libs/glibc/glibc-2.30-r1.ebuild
index b3da5c0345ed..51bf1cbd9f32 100644
--- a/sys-libs/glibc/glibc-2.30-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.30-r1.ebuild
@@ -58,6 +58,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-2.30.ebuild b/sys-libs/glibc/glibc-2.30.ebuild
index 5a8933d5d964..544eec7b6874 100644
--- a/sys-libs/glibc/glibc-2.30.ebuild
+++ b/sys-libs/glibc/glibc-2.30.ebuild
@@ -58,6 +58,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index d529e346178e..6894e04b7965 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -58,6 +58,9 @@ export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
if [[ ${CATEGORY} == cross-* ]] ; then
export CTARGET=${CATEGORY#cross-}
+ # portage's attempt to strip breaks non-native bianries
+ # at least on arm: bug #697428
+ RESTRICT=strip
fi
fi